Red Gate forums :: View topic - Comparing using command line show different but not in GUI
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
SQL Compare 10
SQL Compare 10 forum

Comparing using command line show different but not in GUI

Search in SQL Compare 10 forum
Post new topic   Reply to topic
Jump to:  
Author Message
rre



Joined: 07 Jul 2011
Posts: 29

PostPosted: Wed Sep 05, 2012 12:51 pm    Post subject: Comparing using command line show different but not in GUI Reply with quote

When I comparing a snapshot folder with a database using the command line I getting differences, but there were identical and no differences were highlighted. For that I was using the following parameters in a special XML file:

Code:
<options>IgnoreWhiteSpace,IgnoreConstraintNames,IgnorePermissions,IgnoreQuotedIdentifiersAndAnsiNullSettings</options>


After looking at the comparison report which is also generated by SQL Compare it shows me some objects with differences, but actually there looked identical.

Well, I try with the SQL Compare GUI and used the the same parameter I had used via the command line. The results was that it shows me no differences. Ok, this means is has something to do with the command line version of SQL Compare.

Well, after playing around with some parameters I tried to use the same constraint names in my snapshot folder and my target database to avoid this differences in general although I used the particular option to ignore it. After renaming the constraints on both targets my problem was solved.

I like to share my experience with this strange behavior of the command line from SQL Compare. May be you can reproduce it your environment.
If you need any further information, please let me know.

I used SQL Compare Version 10.2.0.1337
Back to top
View user's profile Send private message
stanori



Joined: 23 Apr 2012
Posts: 72

PostPosted: Fri Sep 07, 2012 8:32 pm    Post subject: Reply with quote

Hi rre,

Thanks for your post. We have opened a support ticket for you in regards to this issue. I will be in contact with you shortly.

Regards,
Steve
_________________
_________________
Steve Tanori
Product Support
Red Gate Software Ltd.
866-997-0378
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group