Red Gate forums :: View topic - SQL Backup 7.1
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
SQL Backup 7
SQL Backup 7 forum

SQL Backup 7.1

Search in SQL Backup 7 forum
Post new topic   Reply to topic
Jump to:  
Go to page Previous  1, 2
Author Message
SQL_ME_RICH



Joined: 08 May 2012
Posts: 60

PostPosted: Thu Jun 28, 2012 1:26 am    Post subject: Re: Reply with quote

PDinCA wrote:
According to James Billings (Red Gate):
Quote:
The GUI (the front end you interact with) can be installed anywhere you want (be it on each server, on your own PC, or somewhere else) and doesn't need to be licensed, so if you have, say, 10 DBA's they can all run the GUI on their own PC.
(See http://www.red-gate.com/MessageBoard/viewtopic.php?t=15106&highlight=cluster), so you should upgrade the UI immediately without issue...


Yeah - I probably confused the issue by describing my workstation console app as being expired (I only use it to see my other servers with licensed Red Gate copies on them).

My concerns are whether or not to upgrade the servers to 7.1, because there is not way that I see to update to 7.1 on my workstation (unless I can simply pull the directory from one of my servers, after I update them, and use it that way).

Is that possible?
Back to top
View user's profile Send private message
SQL_ME_RICH



Joined: 08 May 2012
Posts: 60

PostPosted: Thu Jun 28, 2012 1:28 am    Post subject: Re: Reply with quote

Marianne wrote:

Hi,

I'm afraid we cannot guarantee forwards-compatibility of the user interface. We support backwards-compatibility, meaning that you can run a later version of the UI with an older version of the server components, but not the other way around.

Are you having any problems upgrading the UI to 7.1?

Cheers,

Marianne


Hi Marianne - another user brought up a good point, in that I should be able to run the app from my workstation (even if it is expired - and really that wasn't the point - sorry for the confusion on that). I guess what I need to know is if I uninstall my current copy of Backup 7, update my servers that are currently licensed to 7.1, and then pull one of their folders over to my workstation, will that work?
Back to top
View user's profile Send private message
PDinCA



Joined: 25 Jul 2005
Posts: 503
Location: Costa Mesa, CA, USA

PostPosted: Thu Jun 28, 2012 2:25 am    Post subject: Re: Reply with quote

SQL_ME_RICH wrote:
Yeah - I probably confused the issue by describing my workstation console app as being expired (I only use it to see my other servers with licensed Red Gate copies on them).

My concerns are whether or not to upgrade the servers to 7.1, because there is not way that I see to update to 7.1 on my workstation (unless I can simply pull the directory from one of my servers, after I update them, and use it that way).

Is that possible?

I'll certainly defer to Marianne, being employed by the experts, but when you update the GUI, using Help ==> Check for Updates, and update it, it checks each registered server for the server components and tells you that there's an update available for that server. For stand-alone boxes (non-clustered) I usually update them using the GUI from a central server on the same domain, but for clusters you have to ship the server update file to each node and apply it manually.

Hope this helps.

BTW: I just had an issue upgrading the passive node to 7.1 and provoked a cluster failover! This is because the installer tried to bring the SQL Backup service online as a cluster resource on the PASSIVE Node - faux pas! I hope to have an answer on this issue soon, so you may want to watch it if you have clustered servers. Up to 7.1 I've never had an issue upgrading a passive node, so please beware.
Back to top
View user's profile Send private message
Marianne



Joined: 03 Oct 2011
Posts: 45

PostPosted: Thu Jun 28, 2012 2:59 pm    Post subject: Reply with quote

Hi

I'm not entirely clear on what you want to achieve. It sounds like you're running the UI on your desktop machine and the server components installed on it are no longer licensed, but you have installed server components on other machines and these have valid licenses. Is that right?

You can use the UI where you want - it is not licensed. You can add SQL Servers to the Registered SQL Servers pane on the left of the timeline so that you can manage your SQL Servers from your desktop machine (from the File menu select Add SQL Server. See http://www.red-gate.com/supportcenter/Content/SQL_Backup/help/7.1/SBU_RegisterServers for more details). You need to install the SQL Backup server components on each server and activate the server components with a license key. If the license has expired for a server, you will not be able to perform backup and restore operations on that server (an icon is displayed to indicate this). But the fact that the license has expired on the local server does not mean that you cannot connect to other SQL Servers from the UI and use SQL Backup to perform backup and restore operations on them.

As PDinCA described, if you upgrade the UI to 7.1 (either by using Check for Updates, or by downloading from the website), a cog icon will appear next to each server that you have added to the Registered SQL Servers pane on the left of the timeline to indicate that the version of the server components does not match the UI. If you click the cog icon (or select a Server then select Install or upgrade server components from the Actions menu), you can upgrade the SQL Backup server components on that server. You do not have to upgrade the server components - the UI is backwards compatible, but some features may not be available (these will be indicated in the relevant wizards). See http://www.red-gate.com/supportcenter/Content/SQL_Backup/help/7.1/SBU_InstallingonaSQLServerinstance There is no need to pull folders to your desktop machine.

Alternatively, you can upgrade the server components manually by running SQBServerSetup.exe on the relevant servers (SQBServerSetup.exe is copied to the installation folder when you install/upgrade the UI. By default this is %Program Files%\Red Gate\SQL Backup 7 or %Program Files (x86)%\Red Gate\SQL Backup 7.) This is recommended for clustered installations.

If you want to upgrade the server components without upgrading the UI, you can still add the servers to the UI and manage them from there. However, note that this is not recommended as we do not support forward-compatibility of the UI.

I hope that helps.

Cheers,

Marianne
_________________
Marianne Crowder
Red Gate Software Limited
Back to top
View user's profile Send private message
SQL_ME_RICH



Joined: 08 May 2012
Posts: 60

PostPosted: Fri Jun 29, 2012 12:40 am    Post subject: Reply with quote

Thanks Marianne - I got it resolved.

SQL_ME_RICH
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Go to page Previous  1, 2
Page 2 of 2

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group