Red Gate forums :: View topic - Edit custom metric BadImageformatException HRESULT 0x800700B
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
SQL Monitor 3
SQL Monitor 3 forum

Edit custom metric BadImageformatException HRESULT 0x800700B

Search in SQL Monitor 3 forum
Post new topic   Reply to topic
Jump to:  
Author Message
sean.alexander@ontario.ca



Joined: 28 Mar 2012
Posts: 6

PostPosted: Wed Mar 28, 2012 6:03 pm    Post subject: Edit custom metric BadImageformatException HRESULT 0x800700B Reply with quote

Trying to edit any custom metrics, when I press "save changes", I get the following error:

Code:
/Configuration/Custom-Metrics/Edit/5: 500 error
System.BadImageFormatException: An attempt was made to load a program with an incorrect format. (Exception from HRESULT: 0x8007000B)
at System.Reflection.MetadataImport._GetDefaultValue(IntPtr scope, SkipAddresses& skipAddresses, Int32 mdToken, Int64& value, Int32& length, Int32& corElementType)
at System.Reflection.MdConstant.GetValue(MetadataImport scope, Int32 token, RuntimeTypeHandle fieldTypeHandle, Boolean raw)
at System.Reflection.RuntimeParameterInfo.GetDefaultValue(Boolean raw)
at System.Reflection.RuntimeParameterInfo.get_RawDefaultValue()
at System.Web.Mvc.ParameterInfoUtil.TryGetDefaultValue(ParameterInfo parameterInfo, Object& value)
at System.Web.Mvc.ReflectedParameterDescriptor.get_DefaultValue()
at System.Web.Mvc.ControllerActionInvoker.GetParameterValue(ControllerContext controllerContext, ParameterDescriptor parameterDescriptor)
at System.Web.Mvc.ControllerActionInvoker.GetParameterValues(ControllerContext controllerContext, ActionDescriptor actionDescriptor)
at System.Web.Mvc.ControllerActionInvoker.InvokeAction(ControllerContext controllerContext, String actionName)
at System.Web.Mvc.Controller.ExecuteCore()
at System.Web.Mvc.ControllerBase.Execute(RequestContext requestContext)
at System.Web.Mvc.ControllerBase.System.Web.Mvc.IController.Execute(RequestContext requestContext)
at System.Web.Mvc.MvcHandler.<>c__DisplayClass8.<BeginProcessRequest>b__4()
at System.Web.Mvc.Async.AsyncResultWrapper.<>c__DisplayClass1.<MakeVoidDelegate>b__0()
at System.Web.Mvc.Async.AsyncResultWrapper.<>c__DisplayClass8`1.<BeginSynchronous>b__7(IAsyncResult _)
at System.Web.Mvc.Async.AsyncResultWrapper.WrappedAsyncResult`1.End()
at System.Web.Mvc.MvcHandler.EndProcessRequest(IAsyncResult asyncResult)
at System.Web.Mvc.MvcHandler.System.Web.IHttpAsyncHandler.EndProcessRequest(IAsyncResult result)
at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()
at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)


Configuration > About
(Note: I have tried not using a 32-bit application pool as well, it was initially setup as not allowing 32-bit applications)

Windows Version: Windows 2008 R2

Quote:
Web Server
Version: 3.0.0.1573
Web Server: Microsoft-IIS/7.5
Server Name: http://QRST:31337
Server HOST .NET: .NET 3.5 SP 1
Server Path: D:\Websites\DEV\SQLMonitor-Port-31337
Hosted Environment: 32Bit
User: ABCD\WXYZ$

Base Monitor
Version: 3.0.0.1573
Base Monitor: localhost:31338
Install Location: D:\Program Files\Red Gate\SQL Monitor 3\BaseMonitor
Host Environment: 64Bit
User: ABCD\EFGH
Domain: ABCD
Database: (local) *** RedGateMonitor


This happens on all custom metrics.
Back to top
View user's profile Send private message
fionag



Joined: 05 Jan 2012
Posts: 32
Location: Red Gate

PostPosted: Thu Mar 29, 2012 9:55 am    Post subject: Reply with quote

Sean
Sorry to hear you are having problems. We have already raised a bug for this (SRP-6398) and believe we have a fix. We only have 1 machine here where we see this same issue, so once we have confirmed the fix we will aim to get a release out with this in.
I will update again when we have something more concrete.
Thanks, Fiona
Back to top
View user's profile Send private message
fionag



Joined: 05 Jan 2012
Posts: 32
Location: Red Gate

PostPosted: Fri Mar 30, 2012 12:03 pm    Post subject: Reply with quote

Sean
We are trying to further understand the cause of this issue and have a couple of questions:
1) What versions of .NET do you have installed on the machine(s).
2) Assuming the web and base monitors are on different machines are they both on Windows 2008 R2 (specifically the R2 part)?
Many thanks
Fiona
Back to top
View user's profile Send private message
fionag



Joined: 05 Jan 2012
Posts: 32
Location: Red Gate

PostPosted: Tue Apr 03, 2012 10:11 am    Post subject: Reply with quote

Hi Sean
We have released a bug-fix release that will hopefully resolve this issue. You can download it here
http://www.red-gate.com/products/dba/sql-monitor/download
Please let us know if this doesn't resolve your issue.
Best regards
Fiona
Back to top
View user's profile Send private message
sean.alexander@ontario.ca



Joined: 28 Mar 2012
Posts: 6

PostPosted: Wed Apr 11, 2012 6:06 pm    Post subject: Re: Reply with quote

fionag wrote:
Sean
We are trying to further understand the cause of this issue and have a couple of questions:
1) What versions of .NET do you have installed on the machine(s).
2) Assuming the web and base monitors are on different machines are they both on Windows 2008 R2 (specifically the R2 part)?
Many thanks
Fiona


Sorry I missed this question,

32-bit:
v2.0.50727
3.5
v4.0.30319

64-bit:
v2.0.50727
3.5
v4.0.30319

The Web/Base monitor are on the same machine with IIS 7.5, and SQL Server 2008 R2.

The latest update resolved this issue, and in addition the "custom email over ride not working" is also resolved.

Great work!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group