Red Gate forums :: View topic - Mail problem in v3.0 - custom alerts
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
SQL Monitor 3
SQL Monitor 3 forum

Mail problem in v3.0 - custom alerts

Search in SQL Monitor 3 forum
Post new topic   Reply to topic
Jump to:  
Author Message
mipe10



Joined: 22 Nov 2006
Posts: 46

PostPosted: Tue Mar 27, 2012 8:55 am    Post subject: Mail problem in v3.0 - custom alerts Reply with quote

Hi,
I have created a number of custom metrics and alerts. Everything works fine except for one thing - mail.

In the previous version of sqlMonitor I had a defined default mail profile activated under e-mail settings. Some alerts use this profile to send mail while I on other alerts configured them not to use default mail profile by leaving it empty showing "none" as email notification under alert settings.

In v3.0 you cant set a custom alert to "none". So my question is how do you have a default email profile activated while at the same time you dont want to send mails on specific custom alerts?

Regards
Back to top
View user's profile Send private message Send e-mail
Chris Spencer



Joined: 29 Aug 2006
Posts: 301
Location: Red Gate - Cambridge

PostPosted: Tue Mar 27, 2012 12:24 pm    Post subject: Reply with quote

Hi

I've looked into this and can see that we have a few issues in this area that will need fixing. I've raised a bug report (ref: SRP-6380).

For a workaround, I think you can specify an email address in the alert settings notification override section and it'll save as "none" anyway (that's a bug!). I tested this and didn't receive an alert email for that specific alert.

Regards
Chris
_________________
Chris Spencer
Test Engineer
Red Gate
Back to top
View user's profile Send private message
mipe10



Joined: 22 Nov 2006
Posts: 46

PostPosted: Tue Mar 27, 2012 2:21 pm    Post subject: Reply with quote

Hi,
The workaround worked, thanks..

Regards
Back to top
View user's profile Send private message Send e-mail
mipe10



Joined: 22 Nov 2006
Posts: 46

PostPosted: Tue Mar 27, 2012 2:37 pm    Post subject: Reply with quote

Hi,
I was a little bit to quick. Even though the mailoperator is set to none an email was sent.
Back to top
View user's profile Send private message Send e-mail
Chris Spencer



Joined: 29 Aug 2006
Posts: 301
Location: Red Gate - Cambridge

PostPosted: Tue Mar 27, 2012 3:17 pm    Post subject: Reply with quote

Hi

That's weird - I can't get the email override to work at all. Even overriding with the address I've set as default seems to prevent emails for specific alerts.

I'll continue investigating.

Thanks
Chris
_________________
Chris Spencer
Test Engineer
Red Gate
Back to top
View user's profile Send private message
joffwilliams



Joined: 27 Mar 2012
Posts: 12
Location: Spokane, WA

PostPosted: Tue Mar 27, 2012 4:13 pm    Post subject: Mail problem in v3.0 - custom alerts Reply with quote

Glad to see this is a known bug. Discovered it this morning when working with an alert.

Chris, how does the bug-reporting and fixing process usually work? Should we expect to see a fix rolled out in an update to the software?
Back to top
View user's profile Send private message
Chris Spencer



Joined: 29 Aug 2006
Posts: 301
Location: Red Gate - Cambridge

PostPosted: Tue Mar 27, 2012 4:52 pm    Post subject: Reply with quote

This issue would almost certainly be fixed in the next SQL Monitor release. Whether this release is an update to v3.0 or further down the line in v3.1 is not my decision unfortunately. I'll post here when I know more.

Regards
Chris
_________________
Chris Spencer
Test Engineer
Red Gate
Back to top
View user's profile Send private message
joffwilliams



Joined: 27 Mar 2012
Posts: 12
Location: Spokane, WA

PostPosted: Tue Mar 27, 2012 6:07 pm    Post subject: Mail problem in v3.0 - custom alerts Reply with quote

Thanks, Chris.
Back to top
View user's profile Send private message
Chris Spencer



Joined: 29 Aug 2006
Posts: 301
Location: Red Gate - Cambridge

PostPosted: Fri Mar 30, 2012 2:55 pm    Post subject: Reply with quote

Update: We're fixing this now and there's a good chance that a new build will be available next week.

Chris
_________________
Chris Spencer
Test Engineer
Red Gate
Back to top
View user's profile Send private message
Chris Spencer



Joined: 29 Aug 2006
Posts: 301
Location: Red Gate - Cambridge

PostPosted: Tue Apr 03, 2012 10:14 am    Post subject: Reply with quote

A new build that fixes this issue can now be downloaded.
http://www.red-gate.com/products/dba/sql-monitor/download

Regards
Chris
_________________
Chris Spencer
Test Engineer
Red Gate
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group