Red Gate forums :: View topic - View was deployed despite being unchecked
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
SQL Compare 10
SQL Compare 10 forum

View was deployed despite being unchecked

Search in SQL Compare 10 forum
Post new topic   Reply to topic
Jump to:  
Author Message
fitparrothead



Joined: 31 Jan 2012
Posts: 1
Location: Juno Beach, FL

PostPosted: Tue Jan 31, 2012 4:30 pm    Post subject: View was deployed despite being unchecked Reply with quote

Today I was comparing my test database with my QA database. I had a view that was on both machines but the test database had a newer version that wasn't ready to be deployed to QA yet. I compared the two databases, selected all items, and unchecked one table and one view. I then created the script and ran it. However, the view was in the script and it was synced.

I made another change and was able to reproduce this same behavior again.
Back to top
View user's profile Send private message
james.billings



Joined: 16 Jun 2010
Posts: 1116
Location: My desk.

PostPosted: Wed Feb 01, 2012 9:27 pm    Post subject: Reply with quote

Hi, thanks for posting, and sorry you've had some trouble.

By default we'll often include dependencies. When you ran through the deployment wizard, did you spot if the checkbox was set to include dependencies? This may have been what then included the View.

If the problem persists, then we'll need to investigate a little more.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group