Red Gate forums :: View topic - Checksum comparison issue after v7 -> v9 migration
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
SQL Data Compare Previous Versions
SQL Data Compare Previous Versions forum

Checksum comparison issue after v7 -> v9 migration

Search in SQL Data Compare Previous Versions forum
Post new topic   Reply to topic
Jump to:  
Author Message
harveysburger



Joined: 12 Aug 2008
Posts: 6
Location: Netherlands Antilles

PostPosted: Thu Dec 29, 2011 4:05 pm    Post subject: Checksum comparison issue after v7 -> v9 migration Reply with quote

Since I upgraded from v7 to v9 I can no longer use the option "Use checksum comparison" from the GUI

I get a:
"Validation Failure. Object '[dbo].[SomeTable]' does not exist. ...


The problem affects both SQL Data Compare 9.0.0 and 9.0.1.2 (I installed the patch to solve a different problem... the patch worked for that other problem but didn't help with this one)

Funny thing is that everything works just fine from the command line, I only get the error from the GUI. Since I mostly use sqldatacompare from the command line this problem is not critical to me but I thought I would report it anyway.

I noticed there is a SQL Data Compare_9.1.0.464.zip available for download on the ftp site, would that solve the problem by any chance?

Which leads to the next question... what's new in 9.1.0? I couldn't find anything about it so I assume it's not recommended to install it.



Claude
Back to top
View user's profile Send private message
harveysburger



Joined: 12 Aug 2008
Posts: 6
Location: Netherlands Antilles

PostPosted: Thu Dec 29, 2011 4:18 pm    Post subject: Reply with quote

actually in v7 I used to see calls in Profiler to sp_table_validation to check the rowcount + checksum but with v9 I no longer see that even if the checksum comparison option was turned on.

So I assume in the GUI checksum comparison causes a validation error while on the command line I get no error at all but the checksum is skipped altogether.

I will just stop using that checksum feature for now
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group