Red Gate forums :: View topic - Licensing and Activation Problem
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
SQL Comparison SDK Previous Versions
SQL Comparison SDK Previous Versions forum

Licensing and Activation Problem

Search in SQL Comparison SDK Previous Versions forum
Post new topic   Reply to topic
Jump to:  
Author Message
paul



Joined: 19 Jan 2006
Posts: 10

PostPosted: Fri Dec 02, 2011 6:27 pm    Post subject: Licensing and Activation Problem Reply with quote

I am trying to add the SDK 8 to my project and license and activate Packager (the 3 lines of assemblies in licx). I have followed the instructions and upon building the project I see the Activate box, I click Activate and nothing happens. It displays another Activate box, I click Activate and nothing happens. It does this again for a total of 3 times then fails with 3 build errors that look like this:

Error 4 Exception occurred creating type 'RedGate.SQLCompare.Engine.Database, RedGate.SQLCompare.Engine, Version=7.1.0.182, Culture=neutral, PublicKeyToken=7f465a1c156d4d57' System.IO.FileNotFoundException: Could not load file or assembly 'RedGate.Licensing.Client.resources, Version=2.7.0.3, Culture=en-US, PublicKeyToken=7f465a1c156d4d57' or one of its dependencies. The system cannot find the file specified.

I saw another occurrence of this via google but it was a bit dated so I'm wondering what the current solution or workaround for this is now.

Thanks.
Back to top
View user's profile Send private message
paul



Joined: 19 Jan 2006
Posts: 10

PostPosted: Fri Dec 02, 2011 9:52 pm    Post subject: Reply with quote

fyi, this is with VS 2010 & .Net 4.0.
Back to top
View user's profile Send private message
paul



Joined: 19 Jan 2006
Posts: 10

PostPosted: Fri Dec 02, 2011 10:09 pm    Post subject: Licensing and Activation Problem with VS2010 .Net 4.0 Reply with quote

Ok, this appears to be a problem when targeting .Net 4.0. Recreated the problem when changing the sample proj to target 4.0. Here's the workaround that worked for me.

1) I opened the SDK 8 sample for Automating SQL Packager in VS2010 (converted it upon open).

2) Verified the project was targeting .Net 2.0

3) Built and Activation worked successfully.

4) Verify that proj would build against 4.0 -- Changed proj to target 4.0, rebuilt with success.

5) Opened up *my* non-activatable sln and was able to build it successfully (while targeting 4.0).
Back to top
View user's profile Send private message
Brian Donahue



Joined: 23 Aug 2004
Posts: 6649

PostPosted: Mon Dec 05, 2011 10:08 am    Post subject: Reply with quote

Hi Paul,

Glad to see you have the build working - the issue with SDK licensing DLL remains the same - its' resources are in .NET 2 format so the Microsoft licensing compiler for .net 4 will throw this error.

Since the resources are only used to display the activation dialog, you can activate the SDK licence by building against .NET 2 and then any builds will compile regardless of whether they target .NET 2 or .NET 4. Once the SDK licence is created on the computer, the serial number dialog doesn't need to come up any more and therefore the problem goes away.
Back to top
View user's profile Send private message
youha



Joined: 07 Sep 2011
Posts: 1

PostPosted: Fri Dec 30, 2011 8:54 am    Post subject: Error with licenses.licx - 'Unable to resolve...' Reply with quote

Hi Paul,

Thanks. That really help me a lot! i've been stuck with that error for few days. I followed ur steps and the error just go away Smile

Thanks!
Back to top
View user's profile Send private message Yahoo Messenger MSN Messenger
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group