Red Gate forums :: View topic - InitializeComponent() performance
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
ANTS Performance Profiler 6
ANTS Performance Profiler 6 forum

InitializeComponent() performance

Search in ANTS Performance Profiler 6 forum
Post new topic   Reply to topic
Jump to:  
Author Message
HeathDillon



Joined: 21 Aug 2011
Posts: 1

PostPosted: Mon Aug 22, 2011 12:01 am    Post subject: InitializeComponent() performance Reply with quote

Hi,

New to using this performance tool.. and just starting to learn how it works..

I ran my application, and the result was that the InitializeComponent() code was around 25% of the 'Time'.

This is the standard winforms code that I don't deal with, and looking inside this code section, it looks like the time is being consumed by loading the third party controls I use on the form.

So I assume that there is not realy anything I can do to improve this code section.

The rest of the code is less than 1% time, so there is nothing else really causing a bottle neck, so I guess this is as much performance as I can get from my code.....?
Back to top
View user's profile Send private message
Chris.Allen



Joined: 12 Mar 2009
Posts: 594

PostPosted: Mon Aug 22, 2011 12:50 pm    Post subject: Reply with quote

Indeed- that's exactly what profiling and optimisation is all about- finding out where the bottleneck is. Very often you can't do anything about it directly but at least you know you can't so then you move on.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group