Red Gate forums :: View topic - Error when committing
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
SQL Source Control 2
SQL Source Control 2 forum

Error when committing

Search in SQL Source Control 2 forum
Post new topic   Reply to topic
Jump to:  
Author Message
butlerat



Joined: 22 Jul 2011
Posts: 4
Location: Warwick, England

PostPosted: Fri Jul 22, 2011 2:49 pm    Post subject: Error when committing Reply with quote

I'm getting the following error when attempting to commit my database:

Could not find a part of the path '\\.\con'.

This occurs on the second step (Writing data changes to a temporary directory).

Any ideas on what would be causing this and how to work around it?


Andrew
Back to top
View user's profile Send private message
butlerat



Joined: 22 Jul 2011
Posts: 4
Location: Warwick, England

PostPosted: Fri Jul 22, 2011 2:58 pm    Post subject: Reply with quote

Ok, I think I can guess what is causing the problem.

We have a schema in the database named 'con'.

In Windows, you cannot create an extensionless file named 'con' as this is a reserved filename (used for the console).

This could be fixed if the temporary file being generated had an extension (e.g. con.tmp).

Unfortunately we are unable to change the name of our schema. Hopefully this can be fixed as this bug will stop us purchasing SQL Source Control.
Back to top
View user's profile Send private message
james.billings



Joined: 16 Jun 2010
Posts: 1113
Location: My desk.

PostPosted: Mon Jul 25, 2011 1:05 pm    Post subject: Reply with quote

Thanks for your post.

Checking our bug history at this end, it looks like similar issues have been raised before, but were fixed back in 1.1

If the error you received had a "serious error? send report" link on it, could you please submit that, along with your email address in the box so I can find it, and we can see what's going on?

I agree, it's most likely the "con" that's breaking it.

*Edit* scrub the above, I've found the error report!
Back to top
View user's profile Send private message
butlerat



Joined: 22 Jul 2011
Posts: 4
Location: Warwick, England

PostPosted: Mon Jul 25, 2011 2:42 pm    Post subject: Reply with quote

Thanks for the update.

If you need any testing done on an updated version then let me know and we can test it out.

Regards,

Andrew
Back to top
View user's profile Send private message
butlerat



Joined: 22 Jul 2011
Posts: 4
Location: Warwick, England

PostPosted: Fri Jul 29, 2011 9:52 am    Post subject: Reply with quote

Do you have any idea on if/when we'll get a fix for this?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group