Red Gate forums :: View topic - error while registering database
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
MySQL Compare
MySQL Compare forum

error while registering database

Search in MySQL Compare forum
Post new topic   Reply to topic
Jump to:  
Author Message
bbabic



Joined: 17 May 2011
Posts: 2

PostPosted: Tue May 17, 2011 11:28 am    Post subject: error while registering database Reply with quote

I'm trying to compare two databases on two servers via TCP/IP and I always get error while registering database one.

Code:
Unable to cast object of type 'System.Byte[]' to 'System.String'.


At first, I thought that the problem might be connected with fact that database one uses user with empty password, which is quite common for localhost access in MySQL, but the same thing happens if I try to access it via user with password.
Also, tried to use IP addresses instead of hostnames, but still fails.

So, greetings to test team (is there any?), they probably never got any further than opening dialog at all Smile
Back to top
View user's profile Send private message
bbabic



Joined: 17 May 2011
Posts: 2

PostPosted: Tue May 17, 2011 11:33 am    Post subject: Reply with quote

I usually don't reply to myself, but now I saw that the same bug report was submitted in October 2010!

That much from me - no sense wasting time on non-free software whose developers ignore bug reports.
Back to top
View user's profile Send private message
neil.anderson



Joined: 28 Sep 2010
Posts: 64

PostPosted: Tue May 17, 2011 12:05 pm    Post subject: Reply with quote

Hi bbabic,

You're right. This bug was reported quite a while ago and has not yet been fixed. Myself and a few of the other devs here built the MySQL tools in our Down Tools time http://www.youtube.com/watch?v=nitqtm_ILG8 and as a result there have been long spells where we have either been working on the MySQL Data Compare tool or the SQL Server tools and this bug slipped through the cracks.

In our latest Down Tools week we addressed the main features that our users requested after Lionel's initial EAP last year. They included SSH support, ignoring AUTO INCREMENT and others. Now that those are done we would like to focus on the remaining bugs reported with the latest EAP. This is one of those. We've had one other report of this occuring with the latest build and as yet have been unable to reproduce it.

I appreciate from your last post that you may have given up on this bug but if you are still willing it would be of great help to us if you could turn on verbose logging, reproduce the problem and send the logs to MySQL@red-gate.com. Anything else about the schema (such as SHOW CREATE TABLE outputs) that you can include would also be great.

Thanks,
Neil
Back to top
View user's profile Send private message
neil.anderson



Joined: 28 Sep 2010
Posts: 64

PostPosted: Tue Jun 21, 2011 2:42 pm    Post subject: Reply with quote

Hi bbabic,

This bug is (finally!) fixed. You can download the latest from www.mysql-compare.com .

Regards,
Neil
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group