Red Gate forums :: View topic - Error 880 permission problem with scheduled backup
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
SQL Backup 6
SQL Backup 6 forum

Error 880 permission problem with scheduled backup

Search in SQL Backup 6 forum
Post new topic   Reply to topic
Jump to:  
Go to page 1, 2, 3  Next
Author Message
nmalhot



Joined: 30 Jul 2009
Posts: 2

PostPosted: Thu Jul 30, 2009 9:30 pm    Post subject: Error 880 permission problem with scheduled backup Reply with quote

Hi. Been a long time SQL Backup user ... maybe too long because having a brain fart with just basic setup:

New Windows Web Server 2008 64-Bit Server and new SQLBackup 6.1 installed.

Just want to test my installs and doing a backup on the master db from within SQL Backup works fine. Trying to make a scheduled backup within SQL Backup gives me the following error:

7/30/2009 4:20:25 PM: Backing up master (full database) to:
7/30/2009 4:20:25 PM: D:\MSSQL\MSSQL10.MSSQLSERVER\MSSQL\Backup\FULL_(local)_master_20090730_162025.sqb

7/30/2009 4:20:26 PM: Error 880: BACKUP DATABASE permission denied in database: (master)
7/30/2009 4:20:26 PM: SQL error 15157: Setuser failed because of one of the following reasons: the database principal '28455-DB2\MSSQL_USER' does not exist, its corresponding server principal does not have server access, this type of database principal
cannot be impersonated, or you do not have permission.

The SQL Backup Agent service is running under Administrator and when I connect to MS SQL Manager I use windows authentication and as administrator, that works fine also.

The Activity History in SQL Backup also shows Successful backups on the master db from the MS Backup plan for the same 28455-DB2\MSSQL_USER User Name that is showing as a failure with the SQL Backup scheduled backup.

Any thoughts on what I'm doing wrong?
Back to top
View user's profile Send private message
Anu Deshpande



Joined: 20 Apr 2009
Posts: 692
Location: Cambridge

PostPosted: Mon Aug 03, 2009 10:31 am    Post subject: Reply with quote

Thanks for your post and sorry that this problem has occured.

If this is a scheduled job, SQL Backup relies upon the SQL Server Agent to trigger the job. The SQL Backup Agent Server connects to the SQL Server and checks to see if the user account for the SQL Server Agent has permissions to perform the backup using the setuser command.

SQL Backup can be configured not to perform these additional security checks by adding the SkipChecks registry key, as follows:

1. Using Regedit navigate to the following Registry Folder:
HKEY_LOCAL MACHINE\Software\Red Gate\SQL Backup\BackupSettingsGlobal\(LOCAL) or <SQL Instance Name>

2. Create a new DWORD type registry key called SkipChecks and give this new key a data value of 1.

Once the registry key has been created, SQL Backup will skip the user right checks for backup and restore tasks.

Kindly let us know if this resolves the issue.
_________________
Anuradha Deshpande
Product Support
Redgate Software Ltd.
E-mail: support@red-gate.com
Back to top
View user's profile Send private message Send e-mail
alikar



Joined: 04 Aug 2009
Posts: 2

PostPosted: Tue Aug 04, 2009 6:37 am    Post subject: Reply with quote

I am running Windows 2008 Server x64, SQL Server 2008, and SQL Backup v6.1

I Added the suggested key:

[HKEY_LOCAL_MACHINE\SOFTWARE\Red Gate\SQL Backup\BackupSettingsGlobal\(LOCAL)]
"SkipChecks"=dword:00000001

I am still unable to execute scheduled backups with the following error message appearing for every attempted database backup in the redgate logs:

Quote:
8/3/2009 7:06:39 PM: Backing up model (transaction log) to:
8/3/2009 7:06:39 PM: E:\Microsoft SQL Server\MSSQL10.MSSQLSERVER\MSSQL\Backup\LOG_(local)_model_20090803_190639.sqb

8/3/2009 7:06:39 PM: Error 880: BACKUP DATABASE permission denied in database: (model)
8/3/2009 7:06:39 PM: SQL error 15157: Setuser failed because of one of the following reasons: the database principal 'SERVER\MSSQLAGENT' does not exist, its corresponding server principal does not have server access, this type of database principal cannot be impersonated, or you do not have permission.


As I am sure you are aware, MSDN suggests of SQL 2008 (http://msdn.microsoft.com/en-us/library/ms186297.aspx):

Quote:
SETUSER is included for backward compatibility only. SETUSER may not be supported in a future release of SQL Server. We recommend that you use EXECUTE AS instead.


The article also states:

Quote:
Only use SETUSER with SQL Server users. SETUSER is not supported with Windows users.


Do I need to change my SQL Agent account to run under a SQL Server User? Do you have any other suggestions?

Thank you.
Back to top
View user's profile Send private message
Anu Deshpande



Joined: 20 Apr 2009
Posts: 692
Location: Cambridge

PostPosted: Tue Aug 04, 2009 9:37 am    Post subject: Reply with quote

I am sorry I skipped the point that it is 64-bit server, you will then need to use the following registry node:

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Red Gate\SQL Backup\BackupSettingsGlobal\(local) or SQL Instance Name.

Create a new DWORD type key called SkipChecks and give the key a data value of 1.

Kindly let us know if this fixes the issue.
_________________
Anuradha Deshpande
Product Support
Redgate Software Ltd.
E-mail: support@red-gate.com
Back to top
View user's profile Send private message Send e-mail
nmalhot



Joined: 30 Jul 2009
Posts: 2

PostPosted: Tue Aug 04, 2009 9:07 pm    Post subject: Reply with quote

The registry key fixed my problem. Thanks!
Back to top
View user's profile Send private message
alikar



Joined: 04 Aug 2009
Posts: 2

PostPosted: Tue Aug 04, 2009 9:30 pm    Post subject: Reply with quote

Fixed me, too. Thank you for the quick response!
Back to top
View user's profile Send private message
Anu Deshpande



Joined: 20 Apr 2009
Posts: 692
Location: Cambridge

PostPosted: Wed Aug 05, 2009 3:23 pm    Post subject: Reply with quote

Many thanks for the confirmation.
We are pleased that your issue is resolved :)
_________________
Anuradha Deshpande
Product Support
Redgate Software Ltd.
E-mail: support@red-gate.com
Back to top
View user's profile Send private message Send e-mail
Chris.Allen



Joined: 12 Mar 2009
Posts: 591

PostPosted: Mon Sep 14, 2009 8:28 am    Post subject: Reply with quote

If this doens't work, I find this solves 80% of all such problems:

Run the Red Gate SQL Backup agent as Local System. Job done.
Back to top
View user's profile Send private message
ajgonzalezm



Joined: 18 Feb 2011
Posts: 2

PostPosted: Fri Feb 18, 2011 7:54 pm    Post subject: Same problem Reply with quote

Hi guys,

Got exactly this problem but my server doesn't have the registry key you mentioned! So, what?

Mi SQL Server machine is running on Windows Server Web Service Pack 2 and is a 64 Bit Operating System.

Please help!

Thanks in advance.

Cheers, AJ
Back to top
View user's profile Send private message MSN Messenger
petey



Joined: 24 Apr 2005
Posts: 2306

PostPosted: Sat Feb 19, 2011 1:37 am    Post subject: Reply with quote

If you're using version 6.4, the 'SkipChecks' registry entry should be created in the 'HKEY_LOCAL MACHINE\Software\Red Gate\SQL Backup\BackupSettingsGlobal\(LOCAL) or <SQL Instance Name>' node.
_________________
Peter Yeoh
SQL Backup Consultant Developer
Associate, Yohz Software
Beyond compression - SQL Backup goodies under the hood, updated for version 7
Back to top
View user's profile Send private message Send e-mail
ajgonzalezm



Joined: 18 Feb 2011
Posts: 2

PostPosted: Tue Feb 22, 2011 12:48 am    Post subject: Reply with quote

That worked fine!

Thank you very much.

Best regards,

AJ
Back to top
View user's profile Send private message MSN Messenger
SQLJunkie



Joined: 14 Apr 2011
Posts: 1

PostPosted: Thu Apr 14, 2011 9:52 pm    Post subject: SkipChecks Reply with quote

We are using the 6.4 version and this solution works great for us.

Cheers.
Back to top
View user's profile Send private message
thaicla



Joined: 19 Apr 2011
Posts: 1

PostPosted: Tue Apr 19, 2011 7:36 am    Post subject: Reply with quote

That's working great!

I tried to find this fix for a long time , ha ha.

Thanks.
Back to top
View user's profile Send private message
drueter



Joined: 20 Dec 2006
Posts: 2
Location: California, USA

PostPosted: Fri May 06, 2011 8:33 pm    Post subject: Solution works...please make it permanent Reply with quote

+1 on this solution working on Server 2008 x64 / SQL 2008R2.

I would suggest that Red Gate make this the default--as I don't understand the value of the broken functionality that this registry setting disables.

At a minimum, Red Gate should move the setting from the registry to a configuration setting accessible from the application, and should provide a link or a reference from the error message to that configuration setting.
Back to top
View user's profile Send private message AIM Address Yahoo Messenger MSN Messenger
Markb



Joined: 26 Feb 2008
Posts: 5
Location: Norfolk, United Kingdom

PostPosted: Thu Sep 15, 2011 10:44 am    Post subject: Reply with quote

I've been trying to solve this problem for a day or so now!

Come on Redgate this needs to be addressed! Wasted a lot of time thinking it was a permission issue when actually it isn't.

This registry fix resolved my problem Windows 2008 R2 Standard x64 & SQL 2008 R2 SP1.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Go to page 1, 2, 3  Next
Page 1 of 3

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group