Red Gate forums :: View topic - Unable to attach to the selected process
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation

Memory tracker forum

Unable to attach to the selected process

Search in Memory tracker forum
Post new topic   Reply to topic
Jump to:  
Author Message
AlexBrunner



Joined: 17 Jul 2006
Posts: 2

PostPosted: Mon Jul 17, 2006 6:51 am    Post subject: Unable to attach to the selected process Reply with quote

I just installed the Memory Tracker on my machine.

When I now run the application and select a process to track, I get the error message : Unable to attach to the selected process.

I have local administrator rights.

Could you please tell me what I should do to get it running?

Regards,
Alex
Back to top
View user's profile Send private message
Neil Davidson



Joined: 08 Sep 2004
Posts: 223

PostPosted: Mon Jul 17, 2006 8:08 am    Post subject: Reply with quote

Alex,

Have you installed the debugging tools ( http://www.microsoft.com/whdc/devtools/debugging/default.mspx)?
_________________
- Neil Davidson
Red Gate Software Ltd
Back to top
View user's profile Send private message
AlexBrunner



Joined: 17 Jul 2006
Posts: 2

PostPosted: Mon Jul 17, 2006 9:38 am    Post subject: Reply with quote

Hi Neil

I just installed the mentioned debugging tools. All works fine now.

Thanks for your support.

Regards,
Alex
Back to top
View user's profile Send private message
aheusser



Joined: 29 Jul 2008
Posts: 1

PostPosted: Tue Jul 29, 2008 10:32 pm    Post subject: Unable to attach to the selected process Reply with quote

I'm also getting this error and I did install all the required Windows Debugging tools. I have WinXP SP2 and installed the Windows Symbols for XP SP2 as well as the debugging tools version 6.9.3.113.

I'm trying to track the memory of a .NET 2005 application. I've tried to attach to the debug as well as the release version and I've also run the app from within VS.NET 2005 and attach to the exe that way. No luck.

Any ideas what else could be missing or wrong?

Thanks.
Andi
Back to top
View user's profile Send private message
jmehta_cinci



Joined: 06 Feb 2009
Posts: 1

PostPosted: Fri Feb 06, 2009 10:42 pm    Post subject: Cannot attach to process Reply with quote

I've got Debugging Tools for Windows installed. I tried attaching to the w3wp.exe process, and it couldn't.
Back to top
View user's profile Send private message
Brian Donahue



Joined: 23 Aug 2004
Posts: 6643

PostPosted: Mon Feb 09, 2009 10:57 am    Post subject: Reply with quote

It's not because of the "illegal characters in path" issue, is it?
Back to top
View user's profile Send private message
pcox101



Joined: 18 Dec 2009
Posts: 3

PostPosted: Fri Dec 18, 2009 6:10 pm    Post subject: Getting unable to attach to the selected process Reply with quote

Hi,

The memory tracker tool seemed like just what I needed to analyze the memory usage of a process, but I am getting the "unable to connect to the selected process" error while connecting to any process.

I have installed version 6.11.1.404 of the Debugging Tools for Windows. Windbg fires up fine, but I just don't seem to be able to connect to any process running with the memory tracker.

This is on a Windows Server 2003 machine.

Any ideas? Anything I can do to provide some diagnostics?

Thanks

Pete
Back to top
View user's profile Send private message
Brian Donahue



Joined: 23 Aug 2004
Posts: 6643

PostPosted: Fri Dec 18, 2009 7:00 pm    Post subject: Reply with quote

Hi Pete,

I'm not sure where to look for diagnostics. Just about any process should allow you to attach a debugger. Maybe memory tracker doesn't allow you to connect to unmanaged processes as it's primarily meant for .NET?
Back to top
View user's profile Send private message
pcox101



Joined: 18 Dec 2009
Posts: 3

PostPosted: Fri Dec 18, 2009 9:00 pm    Post subject: Unable to attach.... Reply with quote

Hi,

No, I don't think that's it. The screenshot on the download page has it showing the memory of explorer.exe which I'm pretty sure is unmanaged. Plus the application I'm trying to connect to is partially managed and I've tried it with unmanaged code (reflector) and it doesn't work either.

The thing is I can connect to processes fine using windbg, so I don't think its the debugger.

Maybe the version of the debugging tools for windows is important? I tried to reflect the assemblies but they've been obfuscated (rather obviously) so I can't even help myself to diagnose.

I suspect that the "unable to attach" error is a generic catch all. If there was a bit more information about why it was unable to connect, that would be helpful!

Thanks

Pete
Back to top
View user's profile Send private message
pcox101



Joined: 18 Dec 2009
Posts: 3

PostPosted: Sat Dec 19, 2009 3:08 pm    Post subject: Unable to attach... Reply with quote

Hi,

I have done some more investigation and it looks like the tool requires the following registry key/values:
HKCU\Software\Microsoft\DebuggingTools
. Debugging Help - REG_EXPAND_SZ
. Global Flags - REG_EXPAND_SZ
. Release notes - REG_SZ
. WinDbg - REG_EXPAND_SZ

Set the Debugging Help, Global Flags and WinDbg values to the install folder of debugging tools for windows, "c:\Program Files\Debugging Tools for Windows (x86)\" on my system, and leave the Release notes one empty.

Then on my system the memory tracker could actually connect.

It looks like those keys were removed from the Debugging Tools for Windows in later versions.

Hope that helps anyone who wants to use this tool!

Cheers

Pete
Back to top
View user's profile Send private message
Chris.Allen



Joined: 12 Mar 2009
Posts: 585

PostPosted: Mon Dec 21, 2009 5:06 pm    Post subject: Reply with quote

Brilliant Pete - that certainly helped me!
Back to top
View user's profile Send private message
RobBrooks



Joined: 05 Apr 2010
Posts: 1

PostPosted: Mon Apr 05, 2010 3:48 pm    Post subject: Reply with quote

I'm running Windows 7 and I've just installed the Debugging Tools for Windows and searched for the Registry Keys Pete mentions and I can't find them anywhere.

More info - I downloaded the Microsoft Windows Driver Kit 7.1.0.7600 and *only* checkmarked 'Debugging Tools for Windows'.

Should I have perhaps installed everything?

Like previous posters, I'm currently unable to attach to any process running on this PC with Memory Tracker, although I can attach using windbg.exe
Back to top
View user's profile Send private message
mariaparacha20



Joined: 25 Apr 2011
Posts: 2
Location: albama

PostPosted: Mon Apr 25, 2011 12:31 pm    Post subject: Reply with quote

I'm also getting this error and I did install all the required Windows Debugging tools. I have WinXP SP2 and installed the Windows Symbols for XP SP2 as well as the debugging tools version 6.9.3.113.

I'm trying to track the memory of a .NET 2005 application. I've tried to attach to the debug as well as the release version and I've also run the app from within VS.NET 2005 and attach to the exe that way. No luck.

Any ideas what else could be missing or wrong?
Back to top
View user's profile Send private message Yahoo Messenger
Redgie



Joined: 05 May 2011
Posts: 1
Location: USA

PostPosted: Thu May 05, 2011 3:22 pm    Post subject: Re: Reply with quote

mariaparacha20 wrote:
I'm also getting this error and I did install all the required Windows Debugging tools. I have WinXP SP2 and installed the Windows Symbols for XP SP2 as well as the debugging tools version 6.9.3.113.

I'm trying to track the memory of a .NET 2005 application. I've tried to attach to the debug as well as the release version and I've also run the app from within VS.NET 2005 and attach to the exe that way. No luck.

Any ideas what else could be missing or wrong?

Update your Windows Installer to version 1.1 before installing the debugging tools, maybe you have luck with this. If you are running Windows 2000 or a later version of Windows, then you already have Windows Installer 1.1 or a later version, and there is no need to reinstall it.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group