Red Gate forums :: View topic - Reflector 7.0.1.1 Index was outside the bounds of the array
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
.NET Reflector 7.0 Feedback
.NET Reflector 7.0 Feedback forum

Reflector 7.0.1.1 Index was outside the bounds of the array

Search in .NET Reflector 7.0 Feedback forum
Post new topic   Reply to topic
Jump to:  
Author Message
techtravis



Joined: 01 May 2011
Posts: 2

PostPosted: Sun May 01, 2011 2:08 am    Post subject: Reflector 7.0.1.1 Index was outside the bounds of the array Reply with quote

Hey,

Been using Reflector for about a week now (maybe less). Today all of a sudden whenever I try to open Reflector I get an error stating "Index was outside the bounds of the array."

You should have several error logs sent by me at 9:01pm EST on 4/30/2011 via Smart Assembly.

I should note that I am on Windows 7 64bit, I have visual studio 2010 installed.
I have tried:
Reinstalling Visual Studio
Reinstalling .net 40
Removing all instances of Red Gate from my registry and re-downloading reflector

But I still get the same error message.

Also worthy of note is that I found a copy of Reflector 6.7.3 and that version works fine.
Back to top
View user's profile Send private message
Clive Tong



Joined: 04 Dec 2008
Posts: 283

PostPosted: Tue May 03, 2011 10:15 am    Post subject: Reply with quote

I can't yet find the error report you sent in.

However, the most likely cause is that the configuration files are pointing Reflector at an assembly that is causing it to crash. You should be able to remove the relevant configuration files to get you past the crash.

I'd try removing PersistedTabs that you'll find in your user directory:
C:\Users\clive.tong\AppData\Local\Red Gate\.NET Reflector 7
If that fails, then remove Reflector.cfg
Back to top
View user's profile Send private message
techtravis



Joined: 01 May 2011
Posts: 2

PostPosted: Tue May 03, 2011 12:49 pm    Post subject: Reply with quote

removing the Reflector.cfg took care of the problem, thanks
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group