Red Gate forums :: View topic - Always "An item with the same key has already been added."
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
SQL Source Control 2
SQL Source Control 2 forum

Always "An item with the same key has already been added."

Search in SQL Source Control 2 forum
Post new topic   Reply to topic
Jump to:  
Author Message
rnpi



Joined: 16 Mar 2011
Posts: 2

PostPosted: Wed Mar 16, 2011 3:34 pm    Post subject: Always "An item with the same key has already been added." Reply with quote

I don't know what happened, but sometime yesterday my system stopped being able to compare itself to the database. Now when I choose "Commit Changes" or "Get Latest" there is a short period where the system displays an error dialog which says "An item with the same key has already been added."

This happens when attempting to use "Get Latest" or "Commit Changes".

-- Get Latest Error Details
Code:
System.ArgumentException: An item with the same key has already been added.
   at System.ThrowHelper.ThrowArgumentException(ExceptionResource resource)
   at System.Collections.Generic.Dictionary`2.Insert(TKey key, TValue value, Boolean add)
   at System.Collections.Generic.Dictionary`2.Add(TKey key, TValue value)
   at #oEc.#VXM.#t.#XXM.#tYM(SourceControlOperation )
   at #oEc.#VXM.#t.#WXM.#qYM(SourceControlOperation )
   at #oEc.#VXM.#t.#XXM.#AYM(ToRetrieveChangeSet& toRetrieveChangeSet)
   at #oEc.#VXM.#mYM[#eTb](Func`2 , ICancellableOperationStatus , IReadOnlySourceControlServerCallBacks )
   at #oEc.#VXM.#kYM(ICancellableOperationStatus , IReadOnlySourceControlServerCallBacks )
   at #oEc.#4Ec.#8Jc(ICancellableOperationStatus , IReadOnlySourceControlServerCallBacks )
   at #oEc.#4Ec.#t.#B3.#qfA(ICancellableOperationStatus )
   at #eEc.#iEc.#t.#D3.#i5f()
   at RedGate.SQLSourceControl.Engine.Cancellables.CancellableOperationBase.InvokeWithTracker(Action action)
   at #eEc.#iEc.Invoke()
   at #eEc.#Qlg.Invoke()
   at #JLc.#PLc.#t.#Jfb.#EJf()
   at RedGate.SQLSourceControl.Engine.SmartAssembly.ExceptionReporting.ErrorReporterBase.Do(Action , Predicate`1 , Boolean )
   at RedGate.SQLSourceControl.Engine.SmartAssembly.ExceptionReporting.ErrorReporterBase.DoWithObviousExceptionsRethrowAll(Action action)
   at RedGate.SQLSourceControl.CommonUI.Forms.ErrorDialog.DoWithObviousExceptionsRethrowAll(Action action)
   at #JLc.#PLc.#CTc(ICancellableOperation`1 , Object )
--
Commit Changes Error Details
--
Code:
System.ArgumentException: An item with the same key has already been added.
   at System.ThrowHelper.ThrowArgumentException(ExceptionResource resource)
   at System.Collections.Generic.Dictionary`2.Insert(TKey key, TValue value, Boolean add)
   at System.Collections.Generic.Dictionary`2.Add(TKey key, TValue value)
   at #oEc.#VXM.#t.#XXM.#tYM(SourceControlOperation )
   at #oEc.#VXM.#t.#WXM.#qYM(SourceControlOperation )
   at #oEc.#VXM.#t.#XXM.#zYM(ToCommitChangeSet& toCommitChangeSet)
   at #oEc.#VXM.#mYM[#eTb](Func`2 , ICancellableOperationStatus , IReadOnlySourceControlServerCallBacks )
   at #oEc.#VXM.#jYM(ICancellableOperationStatus , IReadOnlySourceControlServerCallBacks )
   at #oEc.#4Ec.#7Jc(ICancellableOperationStatus , IReadOnlySourceControlServerCallBacks )
   at #oEc.#4Ec.#t.#u3.#ofA(ICancellableOperationStatus )
   at #eEc.#iEc.#t.#D3.#i5f()
   at RedGate.SQLSourceControl.Engine.Cancellables.CancellableOperationBase.InvokeWithTracker(Action action)
   at #eEc.#iEc.Invoke()
   at #eEc.#Qlg.Invoke()
   at #JLc.#PLc.#t.#Jfb.#EJf()
   at RedGate.SQLSourceControl.Engine.SmartAssembly.ExceptionReporting.ErrorReporterBase.Do(Action , Predicate`1 , Boolean )
   at RedGate.SQLSourceControl.Engine.SmartAssembly.ExceptionReporting.ErrorReporterBase.DoWithObviousExceptionsRethrowAll(Action action)
   at RedGate.SQLSourceControl.CommonUI.Forms.ErrorDialog.DoWithObviousExceptionsRethrowAll(Action action)
   at #JLc.#PLc.#CTc(ICancellableOperation`1 , Object )

--


I've uninstalled the product and reinstalled it. It happens on the original install, as well as the small upgrade version. No one else at my company is having this problem. No anti-virus or other software that I'm aware of is running.

If anyone can help it would be greatly appreciated.

Thanks
Back to top
View user's profile Send private message
rnpi



Joined: 16 Mar 2011
Posts: 2

PostPosted: Thu Mar 24, 2011 4:18 pm    Post subject: Reply with quote

Support is on the job. I'll skip all the back and forth but I was told this would be fixed in version 2.1 out in April... probably. If not very soon afterwards.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group