Red Gate forums :: View topic - Other target Framework than 1.1/2.0
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
SQL Packager 6
SQL Packager 6 forum

Other target Framework than 1.1/2.0

Search in SQL Packager 6 forum
Post new topic   Reply to topic
Jump to:  
Author Message
dannyyy



Joined: 14 Feb 2011
Posts: 1

PostPosted: Mon Feb 14, 2011 3:36 pm    Post subject: Other target Framework than 1.1/2.0 Reply with quote

Hi,

We want to generate automatically an executable to give our customer a friendly way to install the database.

Our software projects are in .NET 3.5 / 4.0 and accordingly we use VS 2008 / 2010. But we have left the template project on 2.0.
As soon as we change anything on the GUI in the templeate project which is distributed by RegGate the application can't be run anymore in graphical mode. At first an exception happen that Console.WriteLine use a false handle. (Sure, we are in graphical mode). The internal switch 'consoleMode' doesn't work.
At second, when all Console.WriteLines are fixed the real exception appears. The resource file (*.resx) would not be language neutral. The real problem is, newer version of Visual Studio creates a more modern version of the resource files which can't be read at runtime.

Look at the two examples I have linked. First the original one. The second the one which was generated by adding a new labels and textboxes to the form.

http://www.danflash.com/files/code/Original.resx
http://www.danflash.com/files/code/New.resx

Thank you in advance for any assistances.
Danny
Back to top
View user's profile Send private message
james.billings



Joined: 16 Jun 2010
Posts: 1123
Location: My desk.

PostPosted: Tue Feb 15, 2011 4:36 pm    Post subject: Reply with quote

Thanks for your post.

I'm not quite sure what you mean, could you explain a little more?

I created a C# Project using packager, and opened it up in VS2008. This prompted to upgrade the project which I did. It ran fine. I could add extra controls to the form and it still worked, ok, and I also upgraded the project target to 3.5 - it still ran fine.

Are you integrating the C# project into another solution, and that's where it fails? If you can clarify the steps you're taking I'll see if I can find anything out...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group