Red Gate forums :: View topic - Decompilation problem
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
.NET Reflector 7 EAP
.NET Reflector 7 EAP forum

Decompilation problem

Search in .NET Reflector 7 EAP forum
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.
Jump to:  
Author Message
tekproxy



Joined: 13 Jan 2011
Posts: 1

PostPosted: Thu Jan 13, 2011 6:21 am    Post subject: Decompilation problem Reply with quote

The following IL code seems to cause Reflector to error when decompiling into anything except IL. Removing the first three instructions lets it work again.

Code:
.maxstack 3
    .locals init (
        [0] int32 num)
    L_0000: br L_0007
    L_0005: pop
    L_0006: ldc.i4.0
    L_0007: rest of program here
Back to top
View user's profile Send private message
Clive Tong



Joined: 04 Dec 2008
Posts: 283

PostPosted: Thu Jan 13, 2011 9:06 am    Post subject: Reply with quote

Thanks - I've added that to our bug tracking system.
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies. All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group