Red Gate forums :: View topic - Object not set to instance of an object on EVERYTHING
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
.Net Reflector 6.x and .NET Reflector 6.x Pro
.Net Reflector 6.x and .NET Reflector 6.x Pro forum

Object not set to instance of an object on EVERYTHING

Search in .Net Reflector 6.x and .NET Reflector 6.x Pro forum
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.
Jump to:  
Author Message
_Mr_E



Joined: 08 Dec 2010
Posts: 2

PostPosted: Wed Dec 08, 2010 12:33 am    Post subject: Object not set to instance of an object on EVERYTHING Reply with quote

Upon running I get a "send error report" crash box and then it starts up with everything in error... Except System.ServiceModel.DomainServices.Server.

What have I done wrong?

Back to top
View user's profile Send private message
Clive Tong



Joined: 04 Dec 2008
Posts: 283

PostPosted: Wed Dec 08, 2010 6:10 pm    Post subject: Reply with quote

Hi.

Can you tell us what directories you have under C:\Windows\Microsoft.NET\Framework and what files you have in C:\Windows\Microsoft.NET\Framework\v4.0.30128 ?

Thanks
Back to top
View user's profile Send private message
_Mr_E



Joined: 08 Dec 2010
Posts: 2

PostPosted: Fri Dec 10, 2010 2:51 am    Post subject: Reply with quote

Here's C:\Windows\Microsoft.NET\Framework


As you can see my v.0.30128 has been prefixed with Old_ but here's it's contents anyway (I tried removing the 'Old_' and running reflector but no help):


Here's 4.0.30319 for laughs:
Back to top
View user's profile Send private message
Clive Tong



Joined: 04 Dec 2008
Posts: 283

PostPosted: Mon Dec 13, 2010 10:25 am    Post subject: Reply with quote

It looks like Reflector is configured to point to the v4.0.30128 .NET installation instead of the current 30319, and the former has been cleaned up when the later framework was installed.

I think you need to get Reflector pointing to the new assemblies. An easy way to do this is to delete the assemblies from the assembly list (until it is empty). Then File/Assembly List and chose default. This should then prompt you for the framework version and choosing 4.0 should get Reflector pointing at the newest assemblies.

Does that help?
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies. All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group