Red Gate forums :: View topic - Getting 'Object reference not set to an instance of object'
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
.Net Reflector 6.x and .NET Reflector 6.x Pro
.Net Reflector 6.x and .NET Reflector 6.x Pro forum

Getting 'Object reference not set to an instance of object'

Search in .Net Reflector 6.x and .NET Reflector 6.x Pro forum
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.
Jump to:  
Author Message
aybe



Joined: 28 Oct 2010
Posts: 3

PostPosted: Thu Oct 28, 2010 11:03 pm    Post subject: Getting 'Object reference not set to an instance of object' Reply with quote

I have re-installed the bundle but with no success.
Changed integration with VS a couple of times as well ...

I tried to view the System.Diagnostics.Debug class for instance,
Answering yes or no the question of loading the ones from Program Files doesn't work too.

What I've found is that on the same DLL I can browse internal members but public members always raise the error.

Some DLLs that don't work :

// Module System.dll


Version: e04f7b31-1547-4b53-a83d-8704c8566261
Location: C:\Windows\Microsoft.net\Framework\v4.0.30319\System.dll
Size: 3481928 Bytes
Target Runtime: v4.0.30319
Platform Target: Any

// Module System.Windows.Forms.dll


Version: ec4eb079-760f-4b2c-ad30-17bac4150f59
Location: C:\Windows\Microsoft.net\Framework\v4.0.30319\System.Windows.Forms.dll
Size: 4982120 Bytes
Target Runtime: v4.0.30319
Platform Target: Any

// Module System.Drawing.dll


Version: 881e1508-59e0-47db-a143-982f9ad099a8
Location: C:\Windows\Microsoft.net\Framework\v4.0.30319\System.Drawing.dll
Size: 607064 Bytes
Target Runtime: v4.0.30319
Platform Target: Any


Some that do work :

// Module System.ServiceModel.dll


Version: 9c957b4e-8faa-4589-95a1-724d894c51a9
Location: C:\Windows\Microsoft.net\Framework\v4.0.30319\System.ServiceModel.dll
Size: 6067048 Bytes
Target Runtime: v4.0.30319
Platform Target: Any

// Module System.IdentityModel.dll


Version: 7d49e85d-2239-442b-b0e9-685b07f7368b
Location: C:\Windows\Microsoft.net\Framework\v4.0.30319\System.IdentityModel.dll
Size: 392552 Bytes
Target Runtime: v4.0.30319
Platform Target: Any


// Module System.Workflow.ComponentModel.dll


Version: e83505de-ed1d-4a74-8703-5a10e594bb28
Location: C:\Windows\Microsoft.net\Framework\v4.0.30319\System.Workflow.ComponentModel.dll
Size: 1587064 Bytes
Target Runtime: v4.0.30319
Platform Target: Any

I am running Windows 7 64-bit with VS2010 Ultimate

Any ideas ?

Thank you !
Back to top
View user's profile Send private message
Clive Tong



Joined: 04 Dec 2008
Posts: 283

PostPosted: Fri Oct 29, 2010 4:53 pm    Post subject: Reply with quote

Hi.

Are you talking about viewing the classes in Reflector, or via the Reflector Pro addin to Visual Studio?

What steps are you doing to trigger the null reference exception?

Thanks.
Back to top
View user's profile Send private message
aybe



Joined: 28 Oct 2010
Posts: 3

PostPosted: Sat Oct 30, 2010 9:13 pm    Post subject: Reply with quote

Hello,

It doesn't really matter which way I get onto Reflector,
whether starting it directly, right-clicking my code and choosing
to open Reflector or starting it from the Object Browser.

I am currently using the standard version,
I did try to register/un-register the addin,
clean the VS add-in folder manually,
delete all the DLLs from Reflector and open another 'List',
no success so far.

As I said previously,
internal members works fine but not public ones ...

(Update)
I found that the Silverlight list never fails, it works as it should.
Started to suspect the location of DLLs,
I just tried this right now and it works ...
I copied mscorlib.dll from
C:\Windows\Microsoft.net\Framework\v4.0.30319to D:\Desktop.

Guess what !!??
It works though it's very unpractical ...

Thanks
Back to top
View user's profile Send private message
Clive Tong



Joined: 04 Dec 2008
Posts: 283

PostPosted: Thu Nov 04, 2010 4:48 pm    Post subject: Reply with quote

Hi.

This won't be connected to the addin.

Can you try decompiling one of the public methods of mscorlib, and paste any stacktrace you get?

Thanks
Back to top
View user's profile Send private message
aybe



Joined: 28 Oct 2010
Posts: 3

PostPosted: Thu Nov 04, 2010 7:16 pm    Post subject: Reply with quote

Hello,

You are right, it's not related to Reflector at all.
Beside the send report button, I didn't go further.

Just spent the last two days re-installing and re-configuring my PC.
There was something just not right with VS, hanging issues etc ...
Not much without trouble, I had to re-install twice as on the
first install everything was right except Resharper hanging the whole thing.
I gave it another try, this time I did it minimalistic, no full install everytime;
everything works and it's even a little faster.

So no really answer about the origin of this issue,
but I wouldn't be the first time I see such 'strange behavior' on a system.

Anyway, thank you
Very Happy
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies. All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group