Red Gate forums :: View topic - SQL Response service on Alert Repository server is hung
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
SQL Response 1
SQL Response 1 forum

SQL Response service on Alert Repository server is hung

Search in SQL Response 1 forum
Post new topic   Reply to topic
Jump to:  
Author Message
digitalaaron



Joined: 12 Aug 2010
Posts: 2

PostPosted: Thu Aug 12, 2010 7:04 am    Post subject: SQL Response service on Alert Repository server is hung Reply with quote

I have a problem with the SQL Response service currently running on our Alert Repository server. I tried to make a change to the user name and password that is configured in the service properties. After hitting Apply, I got a warning telling me the changes wouldn't go into effect until the service was stopped and restarted. "No problem", I thought, as I hit the OK button. I'm not sure if the restart tried to process right after the OK button, or if I invoked it directly afterward. Either way, a dialog box with a status popped up and it said the service was being stopped and then started. The progress bar went very slowly, and at the end, I got an error saying that the service was unable to be restarted because it had not been stopped.

At that point I went back to the Services window and saw that the status of the service was "Stopping". It's been like that for several hours now, and as you might expect, we have no access to the monitoring.

Normally I would just reboot the server, but this is part of our high-availability, production system, so downtime is out of the question.

Is there a way to manually force the service to stop and restart? The Alert Repository is running on a Windows 2008 R2 machine and is monitoring two SQL 2008 R2 servers.

Any help would be appreciated.
Back to top
View user's profile Send private message
priyasinha



Joined: 03 Jan 2007
Posts: 530

PostPosted: Wed Aug 18, 2010 2:25 pm    Post subject: Reply with quote

Hi,

I would suggest trying looking for RedGate.SqlResponse.AlertRepository.Service.exe process in task manager. If you see any entry for RedGate.SqlResponse.AlertRepository.Service.exe then end this process. After that try restarting the Alert Repository service again.

Thanks,
Priya
Back to top
View user's profile Send private message
digitalaaron



Joined: 12 Aug 2010
Posts: 2

PostPosted: Wed Aug 18, 2010 4:34 pm    Post subject: Re: Reply with quote

priyasinha wrote:
Hi,

I would suggest trying looking for RedGate.SqlResponse.AlertRepository.Service.exe process in task manager. If you see any entry for RedGate.SqlResponse.AlertRepository.Service.exe then end this process. After that try restarting the Alert Repository service again.

Thanks,
Priya


Thank you, Priva. This is actually what I did to fix the problem. Sorry I didn't update this post once I got it working.
Back to top
View user's profile Send private message
priyasinha



Joined: 03 Jan 2007
Posts: 530

PostPosted: Wed Aug 18, 2010 5:11 pm    Post subject: Reply with quote

Glad to know that it is all working for you now.

Regards,
Priya
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group