Red Gate forums :: View topic - Can not see source code pane (winforms profiling)
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
ANTS Performance Profiler 6
ANTS Performance Profiler 6 forum

Can not see source code pane (winforms profiling)

Search in ANTS Performance Profiler 6 forum
Post new topic   Reply to topic
Jump to:  
Author Message
spallison



Joined: 11 Aug 2010
Posts: 2

PostPosted: Wed Aug 11, 2010 4:26 pm    Post subject: Can not see source code pane (winforms profiling) Reply with quote

I just installed a trial package, so this is an unlicensed trial question.

At first, I could see the source code panel. Then I rebuilt all my source. Now, none of the methods in the profile will show any source. It is as if the source code panel was turned off, and it refuses to show.

I checked my start up projects bin\debug folder and all the pdb files are there and perfectly match the dll files for time of build.

When I try to use the View->Show source view, it is neither bolded nor do I get any response whatsoever. I really want to see the break down in the methods.

This software shows real promise to focus me to exactly where my performance issues are and I'm excited to get use out of it, and try to get a purchase approved.

But I'd really like to see the source again at it was showing earlier this day.
Back to top
View user's profile Send private message
SharedProphet



Joined: 10 Aug 2010
Posts: 3

PostPosted: Wed Aug 11, 2010 5:13 pm    Post subject: Reply with quote

I had the same problem, with the full version. Solution is here:
http://www.red-gate.com/MessageBoard/viewtopic.php?p=41870
Back to top
View user's profile Send private message
spallison



Joined: 11 Aug 2010
Posts: 2

PostPosted: Wed Aug 11, 2010 5:26 pm    Post subject: Reply with quote

Thank you shared prophet that did the trick.

To be explicit, I simply did the following:

Delete all the registry entries in:
HKEY_CURRENT_USER\Software\Red Gate\ANTS Performance Profiler 6\Dock States\
Back to top
View user's profile Send private message
StephenC



Joined: 15 Oct 2007
Posts: 315
Location: Cambridge

PostPosted: Wed Aug 11, 2010 9:54 pm    Post subject: Reply with quote

Thanks SharedProphet,

nice to see you are helping users out on the forums for us. The tech support team are very happy and have asked if you can stick around for longer?
Very Happy

Just to clarify on this issue - there's a bug of some sort in the docking component being used to display the windows. We cannot appear to work around it from within the ANTS UI and the only solution so far is to manually delete the registry keys.

Regards,

Stephen
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group