Red Gate forums :: View topic - Aggregate Ignored By packager
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
SQL Packager 6
SQL Packager 6 forum

Aggregate Ignored By packager

Search in SQL Packager 6 forum
Post new topic   Reply to topic
Jump to:  
Author Message
chrisrm



Joined: 03 Nov 2009
Posts: 5

PostPosted: Wed Jan 20, 2010 1:23 pm    Post subject: Aggregate Ignored By packager Reply with quote

I have encountered an issue with the SQL Packager. I have a .Net CLR UDA which takes in an additional parameter. The packager ignores this aggregate and omits it from the generated SQL batches for the database ugrade.

If I run the SQL code manually to create the aggregate, there is no problem and it all works. However, it would be preferable for this to work in the packager.

My create aggregate SQL is as follows:-

CREATE AGGREGATE Helper.[Concatenate](@input NVARCHAR(MAX), @separator NCHAR(1))
RETURNS NVARCHAR(MAX)
EXTERNAL NAME [MyDll].[Aggregates.Concatenate];
GO
Back to top
View user's profile Send private message
peter.peart
Site Admin


Joined: 02 Sep 2008
Posts: 362
Location: Top floor, RG towers with the cool kids

PostPosted: Thu Jan 21, 2010 8:03 pm    Post subject: Reply with quote

Hi Chris,

Many thanks for your post. Can you confirm if you experience this behaviour with SQL Packager 6.3?

There is a sticky detailed below with the latest patch release 6.3:

http://www.red-gate.com/messageboard/viewtopic.php?t=9883

Many thanks!

Pete
_________________
Peter Peart
Red Gate Software Ltd
+44 (0)870 160 0037 ext. 8569
1 866 RED GATE ext. 8569
Back to top
View user's profile Send private message Send e-mail
chrisrm



Joined: 03 Nov 2009
Posts: 5

PostPosted: Fri Jan 22, 2010 9:37 am    Post subject: Reply with quote

Pete,

I am using version 6.3.1.7 of the packager.

Chris
Back to top
View user's profile Send private message
peter.peart
Site Admin


Joined: 02 Sep 2008
Posts: 362
Location: Top floor, RG towers with the cool kids

PostPosted: Fri Feb 05, 2010 2:36 pm    Post subject: Reply with quote

Hi Chris,

Thanks for letting me know. I have one of our devs looking at this now; hopefully we should be able to include a patch for this soon for you.

Pete
_________________
Peter Peart
Red Gate Software Ltd
+44 (0)870 160 0037 ext. 8569
1 866 RED GATE ext. 8569
Back to top
View user's profile Send private message Send e-mail
peter.peart
Site Admin


Joined: 02 Sep 2008
Posts: 362
Location: Top floor, RG towers with the cool kids

PostPosted: Thu Feb 18, 2010 4:31 pm    Post subject: Reply with quote

Hi Chris,

Just so you are aware, this issue has been raised under ref SPA-540. I will let you know as and when we have a fix for it.

Pete
_________________
Peter Peart
Red Gate Software Ltd
+44 (0)870 160 0037 ext. 8569
1 866 RED GATE ext. 8569
Back to top
View user's profile Send private message Send e-mail
chrisrm



Joined: 03 Nov 2009
Posts: 5

PostPosted: Mon Jul 12, 2010 9:58 am    Post subject: Reply with quote

Any idea when this fix will be included?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group