Red Gate forums :: View topic - UriFormatException profiling ASP.NET website
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
ANTS Memory Profiler Previous Versions
ANTS Memory Profiler Previous Versions forum

UriFormatException profiling ASP.NET website

Search in ANTS Memory Profiler Previous Versions forum
Post new topic   Reply to topic
Jump to:  
Author Message
glaxaco



Joined: 27 May 2010
Posts: 2

PostPosted: Thu May 27, 2010 4:19 pm    Post subject: UriFormatException profiling ASP.NET website Reply with quote

Hello,

I am having trouble using the ANTS memory profiler on an ASP.NET website. In my VS 2008 solution, I have the website selected as the Startup project. When I select "Profile Memory" from the ANTS 5 menu, I get the following error:

System.UriFormatException: Invalid URI: The URI is empty.
at System.Uri.CreateThis(String ur, Boolean dontEscape, UriKind uriKind)
at System.Uri..ctor(String uriString)
at RedGate.Memory.AddIn.Commands.ProfileCommand.get_LaunchArguments()
at RedGate.Memory.AddIn.Commands.ProfileMemoryCommand.RunCommand()
at RedGate.Memory.AddIn.Connect.Exec(String commandName, vsCommandExecOption executeOption, Object& varIn, Object& varOut, Boolean& handled)

This seems like it should be a simple thing, but I can't find any documentation specifically outlining how to profile a web app from within Visual Studio. Anyone have any pointers?

Thanks,

Eric
Back to top
View user's profile Send private message
Brian Donahue



Joined: 23 Aug 2004
Posts: 6674

PostPosted: Fri May 28, 2010 5:45 pm    Post subject: Reply with quote

Hi Eric,

There is a bug in the ANTS Profiler add-in when it comes to ASP .NET. We do have a patched version of the add-in that should fix the problem:

1) Download this file: ftp://support.red-gate.com/patches/ants_profiler/RedGate.Profiler.Five.AddIn.dll

2) Put it in your ANTS install directory, replacing a file with the same name.

3) Restart Visual Studio.
Back to top
View user's profile Send private message
glaxaco



Joined: 27 May 2010
Posts: 2

PostPosted: Fri May 28, 2010 7:12 pm    Post subject: Reply with quote

Unfortunately, I followed the steps and got the same result.

I'm not sure the FTP version is correct. The version of (program files)\Red Gate\ANTS Performance Profiler 5\RedGate.Profiler.Five.AddIn.dll is 5.2.0.26. The version on the FTP site is 5.1.0.8 - should it be going backward?

Thanks,

Eric
Back to top
View user's profile Send private message
slaphead99



Joined: 10 Mar 2010
Posts: 93

PostPosted: Tue Jun 01, 2010 1:31 pm    Post subject: Reply with quote

Sometimes you have to go backwards to go forwards. Wink
Back to top
View user's profile Send private message
slaphead99



Joined: 10 Mar 2010
Posts: 93

PostPosted: Wed Jun 02, 2010 8:10 pm    Post subject: Reply with quote

Ah sorry- I re-read this. The add-in only solves the issue for the *performance profiler* not the memory profiler- my colleague is working on a patch for the memory profiler right now. I'll check how near he is with this.
Back to top
View user's profile Send private message
slaphead99



Joined: 10 Mar 2010
Posts: 93

PostPosted: Mon Jun 07, 2010 7:26 pm    Post subject: Reply with quote

We attempted a patch and it fixed this problem but had a few side-effects which render it not publishable. So, I think we'll just have to wait for it to be fixed in the general release.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group