Red Gate forums :: View topic - No methods to delve into
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
ANTS Performance Profiler 5
ANTS Performance Profiler 5 forum

No methods to delve into

Search in ANTS Performance Profiler 5 forum
Post new topic   Reply to topic
Jump to:  
Author Message
im1dermike



Joined: 28 Apr 2010
Posts: 4

PostPosted: Wed Apr 28, 2010 4:32 pm    Post subject: No methods to delve into Reply with quote

Iíve watched a number of walkthrough and tutorial videos. It looks like there are a ton of features available in the ANTS Performance Profiler which Iím anxious to utilize.

The particular issue Iím facing is that the Login page of my website loads extremely slowly. There is no code being executed on the Page_Load (only ASP controls are initialized) so Iím having trouble identifying the issue. This has me leaning toward the source of the issue being outside of my web app code. When I run ANTS on my websiteís login page, this is what I get:



The only task accomplished during this profiling session was the Login page loading. As you can see, it took a long time. Iíd like to be able to analyze the profile using information I learned in the videos, but there is only one method listed which I canít delve into. I found a "Working with the call tree" description on the ANTS website, but all it says is "Transition to managed code: A transition from unmanaged code to managed code occurred at this point in the stack trace."

Additionally, the single event that is occurring during this profiling is a System.Configuration.ConfigurationErrorsException.

Can anyone provide any insight? Thanks in advance
Back to top
View user's profile Send private message
im1dermike



Joined: 28 Apr 2010
Posts: 4

PostPosted: Wed Apr 28, 2010 5:03 pm    Post subject: Reply with quote

I know it's the PreRender of the <asp:Login> control that takes so long. I just can't figure out why. I think it's that ASP makes a behind-the-scenes connection to the MembershipProvider for the Login control, but how do you debug that? ANTS isn't helping.
Back to top
View user's profile Send private message
slaphead99



Joined: 10 Mar 2010
Posts: 93

PostPosted: Thu Apr 29, 2010 5:21 pm    Post subject: Reply with quote

Best thing to do, at this point is reduce profiling overhead by selecting the "fastest, most accurate" mode of profiling.

To get more info from the call tree view- deselect the "hide insignificant methods" checkbox.
Back to top
View user's profile Send private message
im1dermike



Joined: 28 Apr 2010
Posts: 4

PostPosted: Thu Apr 29, 2010 5:22 pm    Post subject: Reply with quote

Not sure if this makes me an idiot, but I believe I wasn't seeing any methods because I was profiling a pre-compiled site. I switched to the source version of that site and I now have something to work with.
Back to top
View user's profile Send private message
slaphead99



Joined: 10 Mar 2010
Posts: 93

PostPosted: Fri Apr 30, 2010 5:24 pm    Post subject: Reply with quote

That's more our issue really- we should probably make it clearer when PDBs have not been found. Anyway- glad your up and running and thanks for "self-helping" Smile
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group