Red Gate forums :: View topic - COMException when using "Profile Performance" in VS 2008
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
ANTS Performance Profiler 5
ANTS Performance Profiler 5 forum

COMException when using "Profile Performance" in VS 2008

Search in ANTS Performance Profiler 5 forum
Post new topic   Reply to topic
Jump to:  
Author Message
JPA



Joined: 15 Oct 2009
Posts: 2

PostPosted: Thu Oct 15, 2009 10:19 am    Post subject: COMException when using "Profile Performance" in VS 2008 Reply with quote

Hi,

I can start the Performace Profiler without problems directly, but when I start it via "ANTS 5 -> Profile Performance" inside VS 2008, I get the following error:

---------------------------
Exception while performing Profile &Performance
---------------------------
System.Runtime.InteropServices.COMException (0x8000FFFF): Schwerwiegender Fehler (Exception from HRESULT: 0x8000FFFF (E_UNEXPECTED))
at EnvDTE.Project.get_ConfigurationManager()
at a.c(Project )
at RedGate.Profiler.AddIn.Commands.ProfileCommand.get_LaunchArguments()
at RedGate.Profiler.AddIn.Commands.ProfileCommand.RunCommand()
at RedGate.Profiler.AddIn.Five.Connect.Exec(String commandName, vsCommandExecOption executeOption, Object& varIn, Object& varOut, Boolean& handled)

If you need further information, let me know.

Thanks!
Back to top
View user's profile Send private message
Chris.Allen



Joined: 12 Mar 2009
Posts: 591

PostPosted: Fri Oct 16, 2009 11:18 am    Post subject: Reply with quote

Hmm, Catastrophic failure from the add-in.

Can you try replacing the existing addin dll with this please:

ftp://support.red-gate.com/Patches/ANTS_Profiler/RedGate.Profiler.Five.AddIn.dll
Back to top
View user's profile Send private message
JPA



Joined: 15 Oct 2009
Posts: 2

PostPosted: Fri Oct 16, 2009 11:46 am    Post subject: Reply with quote

Hi,

this didn't help, but I think I found the problem.
This error only occurs when the startup project isn't a C#-project but an exe file.
If I set a C# project as startup (with the exe as "start external progam" in the debug tab in the project properties) then the profiler works perfectly.

Most of the time I create libraries and for debugging I just add the application exe as project. Perhaps you should fix that in the profiler so it also works that way.
Back to top
View user's profile Send private message
Chris.Allen



Joined: 12 Mar 2009
Posts: 591

PostPosted: Wed Oct 28, 2009 9:09 pm    Post subject: Reply with quote

Thanks for finding the solution. I will suggest this enhancement to our guys.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group