Red Gate forums :: View topic - Erratic Tooltips
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
SQL Prompt Previous Versions
SQL Prompt Previous Versions forum

Erratic Tooltips

Search in SQL Prompt Previous Versions forum
Post new topic   Reply to topic
Jump to:  
Author Message
Dave Pendleton



Joined: 19 Aug 2007
Posts: 46
Location: St. Paul, MN

PostPosted: Thu Sep 10, 2009 9:22 pm    Post subject: Erratic Tooltips Reply with quote

Why are tooltips present for some columns/objects and not for others?

When working on a SELECT statement with multiple JOIN clauses, tooltips appear for some columns/tables but not for others.

The syntax of the SELECT is correct and runs as expected.

Refresh Suggestions does nothing.
Back to top
View user's profile Send private message
Anu Deshpande



Joined: 20 Apr 2009
Posts: 685
Location: Cambridge

PostPosted: Mon Sep 14, 2009 1:22 pm    Post subject: Reply with quote

Hello Dave,

Thanks for your post.

Can you kindly let us know the query using which I can replicate the issue?

This will help us to investigate the issue further.
_________________
Anuradha Deshpande
Product Support
Redgate Software Ltd.
E-mail: support@red-gate.com
Back to top
View user's profile Send private message Send e-mail
Dave Pendleton



Joined: 19 Aug 2007
Posts: 46
Location: St. Paul, MN

PostPosted: Wed Sep 16, 2009 3:11 pm    Post subject: Reply with quote

There is no specific query that causes this to occur. Usually, it is just a SELECT with one or more JOIN clauses (and aliased tables).

I have also noticed erratic behavior when using table aliases without the AS keyword, although I don't know if this is related. Sometimes including AS and refreshing suggestions will help.

Usually, I cut the SQL from the Query Window, open a new window, paste the SQL, refresh suggestions and then tooltips will work as expected.
Back to top
View user's profile Send private message
Anu Deshpande



Joined: 20 Apr 2009
Posts: 685
Location: Cambridge

PostPosted: Mon Sep 21, 2009 11:21 am    Post subject: Reply with quote

Thanks for the update Dave.

I am trying to replicate the issue but it works fine for me.

Can you kindly let us know whether the tooltips doesn't work for any specific objects?
_________________
Anuradha Deshpande
Product Support
Redgate Software Ltd.
E-mail: support@red-gate.com
Back to top
View user's profile Send private message Send e-mail
Dave Pendleton



Joined: 19 Aug 2007
Posts: 46
Location: St. Paul, MN

PostPosted: Tue Nov 30, 2010 5:35 pm    Post subject: Reply with quote

A year later, and this is still not resolved.

Is there a limit to the length of a SELECT statement?

I have a SELECT statement with 89 columns, many of which are CASE statements. After 79 columns, the tips stop working. Anything above that they work fine.
Back to top
View user's profile Send private message
Dave Pendleton



Joined: 19 Aug 2007
Posts: 46
Location: St. Paul, MN

PostPosted: Tue Dec 07, 2010 5:14 pm    Post subject: Column metatdata does not appear Reply with quote

In addition, when opening this source file (a view in VS2005), tooltips appear for functions when I click the column name, e.g.

Code:

LEN([My Column]) = 0


but no column metadata appears when I hover over (or click) the column name. The syntax of the SQL (as a whole) is correct.

Refreshing suggestions does not help.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group