Red Gate forums :: View topic - IIS app profiling is odd.
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
ANTS Memory Profiler Previous Versions
ANTS Memory Profiler Previous Versions forum

IIS app profiling is odd.

Search in ANTS Memory Profiler Previous Versions forum
Post new topic   Reply to topic
Jump to:  
Author Message
sseely



Joined: 08 Aug 2009
Posts: 5

PostPosted: Sat Aug 08, 2009 9:06 pm    Post subject: IIS app profiling is odd. Reply with quote

Environment: Win7 x64, IIS 7.5
Memory Profiler Version: 5.1.0.15

Tried running Memory Profiler as limited user and as admin, results are identical.

Steps to repro:
1. Install BuggyBits example from here as a web app in IIS: http://blogs.msdn.com/tess/pages/net-debugging-demos-information-and-setup-instructions.aspx (buggybits site is an attachment at the end of the post)

2. In App Settings, select application type to profile: ASP.NET web application (hosted in IIS)
URL: http://127.0.0.1:80/BuggyBits
Profile On: Original Port (IIS will reset)

3. Click on 'Start Profiling'

Memory Profiler is stuck on 'Starting application...' and won't go to the next stage until I navigate to a few pages within the app. Why?
Back to top
View user's profile Send private message
Chris.Allen



Joined: 12 Mar 2009
Posts: 594

PostPosted: Mon Aug 10, 2009 2:44 pm    Post subject: Reply with quote

I'm investigatng this (thanks for the steps). In the meantime can you try the same procedure and ensure no other web sites are using port 80?
Back to top
View user's profile Send private message
Chris.Allen



Joined: 12 Mar 2009
Posts: 594

PostPosted: Mon Aug 10, 2009 4:41 pm    Post subject: Reply with quote

Well, I've got my BuggyBits up and running and profiling nicely. I'm using 64-bit Win 2008, IIS7; same ANTS version as yourself. I'm the local administrator. I expect it is a permissions issue. As another suggestion, can you also try using the "unused port" option?
Back to top
View user's profile Send private message
sseely



Joined: 08 Aug 2009
Posts: 5

PostPosted: Sat Aug 15, 2009 8:40 pm    Post subject: Reply with quote

Chris,
I have the following settings:
App type to profile: ASP.NET Web Application (hosted in IIS)
ASP.NET web application URL: http://localhost/BuggyBits
Profile on: Original port

The profiling still doesn't kick in (that is, I can't select Take Memory Snapshot) until I navigate to a new page, like http://localhost/BuggyBits/News.aspx.
Back to top
View user's profile Send private message
AndrewH



Joined: 17 Aug 2006
Posts: 137

PostPosted: Tue Aug 18, 2009 12:59 pm    Post subject: Reply with quote

That's not unexpected, I think: the profiling should only start when the .NET runtime is loaded by IIS, which doesn't happen until you navigate to the first .aspx page in this case.

There's actually no memory being used by .NET at all until this happens, which is why the take snapshot button remains disabled.
_________________
Andrew Hunter
Software Developer
Red Gate Software Ltd.
Back to top
View user's profile Send private message
sseely



Joined: 08 Aug 2009
Posts: 5

PostPosted: Tue Aug 18, 2009 6:30 pm    Post subject: Reply with quote

Thanks. that makes sense, though it was a bit surprising at first. Might be worth some documentation (or is this fact in there already?).
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group