Red Gate forums :: View topic - MSI Installation Failure (1603)
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
ANTS Performance Profiler 5
ANTS Performance Profiler 5 forum

MSI Installation Failure (1603)

Search in ANTS Performance Profiler 5 forum
Post new topic   Reply to topic
Jump to:  
Author Message
Chris.Allen



Joined: 12 Mar 2009
Posts: 593

PostPosted: Fri Jun 26, 2009 1:03 pm    Post subject: MSI Installation Failure (1603) Reply with quote

1603 is a generic error but we are getting a lot of these lately so you can safely assume if you're getting this with version 5 the following is a reliable workaround:

If you have a user who you know has never ran Visual Studio xxxx (and if you are unsure and you are able- create one), log in and install ANTS from there. You'll still need admin rights.

This only works for one of the products though. We will fix this soon in the next build...
Back to top
View user's profile Send private message
Jorriss



Joined: 30 Jun 2009
Posts: 1

PostPosted: Tue Jun 30, 2009 10:39 pm    Post subject: MSI Installation Failure (1603) Reply with quote

So when is the next build going to be released? I'm trying to test drive the product and I can't get it to install.
Back to top
View user's profile Send private message
Chris.Allen



Joined: 12 Mar 2009
Posts: 593

PostPosted: Thu Jul 02, 2009 5:42 pm    Post subject: Reply with quote

Sorry that you're still having troubles, I'll post as soon as I know...
Back to top
View user's profile Send private message
commongenius



Joined: 16 Dec 2008
Posts: 4

PostPosted: Wed Jul 08, 2009 7:47 pm    Post subject: ResetAddin hanging Reply with quote

When I tried to install, the ResetAddin task for VS 2005 ran for over 45 minutes before I was finally forced to shut it down so I could get on with my work. When I did that the installation failed with 1603. Is this the program you will be fixing in the next release, and can you please tell me when I can expect that to be?
Back to top
View user's profile Send private message
Chris.Allen



Joined: 12 Mar 2009
Posts: 593

PostPosted: Fri Jul 10, 2009 5:31 pm    Post subject: Reply with quote

We will release version 5.1 on Tuesday 14th July. This will fix the current installation problems. Sorry for the delay.
Back to top
View user's profile Send private message
OliverG



Joined: 08 Apr 2009
Posts: 7

PostPosted: Thu Jul 16, 2009 1:41 pm    Post subject: Reply with quote

Well I am still getting a 1603 error with the new 5.1 setup Sad
Back to top
View user's profile Send private message
Chris.Allen



Joined: 12 Mar 2009
Posts: 593

PostPosted: Thu Jul 16, 2009 3:56 pm    Post subject: Reply with quote

Yes, 1603 is actually a generic error (5.1 only solves one issue but it was occuring very frequently). Can you get hold of the install log file. Click on the very top left corner of the installer and the menu will give you acces to the log file. If there are grumblings about VBScript, try this:

Running CMD.exe as Administrator:

cd %windir%\System32

regsvr32 vbscript.dll

or this, on x64:

cd to C:\windows\syswow64

Type- regsvr32 vbscript.dll, then hit enter.
Back to top
View user's profile Send private message
OliverG



Joined: 08 Apr 2009
Posts: 7

PostPosted: Tue Jul 21, 2009 3:50 pm    Post subject: Reply with quote

Hehe thanks, that worked fine Smile but why ?
Back to top
View user's profile Send private message
Chris.Allen



Joined: 12 Mar 2009
Posts: 593

PostPosted: Wed Jul 29, 2009 7:12 pm    Post subject: Reply with quote

I think its because vbscript.dll is not registered by default on some machines (security reasons I think). There is plenty of info in googlespace on this. e.g.:

http://social.msdn.microsoft.com/Forums/en-US/tfspowertools/thread/e940015e-0463-4501-b973-bdc5f63086b8
Back to top
View user's profile Send private message
three_sixteen



Joined: 21 Dec 2009
Posts: 1

PostPosted: Mon Dec 21, 2009 10:07 pm    Post subject: Reply with quote

Hate to bring back an old thread, but I'm running into this problem as well and I've tried the fix noted here.

I'm running Server 2008 R2 x64

I narrowed down the performance profiler MSI and tried to install it with logging, heres a snippet of what's in it..

Code:

Property(C): MsiRunningElevated = 1
Property(C): Privileged = 1
Property(C): USERNAME = Windows User
Property(C): DATABASE = C:\Users\austin\Desktop\ANTSProfiler_5.2.0.26_AnyCpu_r99081\ANTSProfiler_5.2.0.26_x64_r99081.msi
Property(C): OriginalDatabase = C:\Users\austin\Desktop\ANTSProfiler_5.2.0.26_AnyCpu_r99081\ANTSProfiler_5.2.0.26_x64_r99081.msi
Property(C): SOURCEDIR = C:\Users\austin\Desktop\ANTSProfiler_5.2.0.26_AnyCpu_r99081Property(C): VersionHandler = 5.00
Property(C): ROOTDRIVE = J:Property(C): EXECUTEACTION = INSTALL
Property(C): ACTION = INSTALL
Property(C): UILevel = 5
Property(C): CostingComplete = 0
Property(C): OutOfDiskSpace = 0
Property(C): OutOfNoRbDiskSpace = 0
Property(C): PrimaryVolumeSpaceAvailable = 0
Property(C): PrimaryVolumeSpaceRequired = 0
Property(C): PrimaryVolumeSpaceRemaining = 0
Property(C): INSTALLLEVEL = 1
=== Logging stopped: 12/21/2009  14:05:11 ===
MSI (c) (A4:24) [14:05:11:426]: Product: ANTS Performance Profiler 5 -- Installation failed.

MSI (c) (A4:24) [14:05:11:428]: Windows Installer installed the product. Product Name: ANTS Performance Profiler 5. Product Version: 5.2.0.26. Product Language: 1033. Manufacturer: Red Gate Software Ltd. Installation success or error status: 1603.


Also I just tried to install again, found this error in the bundle installer's log:

Code:

[2009-12-21 21:13:58] INSTALL PRODUCTS
[2009-12-21 21:13:58] TO INSTALL: ANTS Performance Profiler 5.2
[2009-12-21 21:13:58] Upgrade Code: {2094fc68-a4fc-4ad5-9b85-b846ae6fc004}
[2009-12-21 21:13:58] Target Location: "C:\Program Files\Red Gate\ANTS Performance Profiler 5"
[2009-12-21 21:13:58] TO INSTALL: ANTS Memory Profiler 5.1
[2009-12-21 21:13:58] Upgrade Code: {ce0d94e4-4347-4313-9c33-06ac6d981842}
[2009-12-21 21:13:58] Target Location: "C:\Program Files\Red Gate\ANTS Memory Profiler 5"
[2009-12-21 21:13:58] TO INSTALL: Exception Hunter 2.1
[2009-12-21 21:13:58] Upgrade Code: {3fe396ea-9114-11dc-8314-0800200c9a66}
[2009-12-21 21:13:58] Target Location: "C:\Program Files\Red Gate\Exception Hunter 2"
[2009-12-21 21:13:59] Failed to find all running processes!
[2009-12-21 21:13:59] System.ComponentModel.Win32Exception: Access is denied
   at System.Diagnostics.ProcessManager.OpenProcess(Int32 processId, Int32 access, Boolean throwIfExited)
   at System.Diagnostics.NtProcessManager.GetModuleInfos(Int32 processId, Boolean firstModuleOnly)
   at System.Diagnostics.Process.get_MainModule()
   at RedGate.InstallerWizard.Engine.ProductSet.FindProgramsRunning(IList`1& running)
[2009-12-21 21:13:59] Msi Path ANTSProfiler_5.2.0.26_AnyCpu_r99081\ANTSProfiler_5.2.0.26_x64_r99081.msi for x64
[2009-12-21 21:13:59] Tasks ANTS Performance Profiler 5.2 Performance profiling for .NET developers
[2009-12-21 21:13:59] CMD File Version C:\Program Files\Common Files\System\msadc\msdfmap.dll LESS_THAN
[2009-12-21 21:13:59] CMD File Eval False
[2009-12-21 21:13:59] CMD OS Win32NT V6.1 Evals to False
[2009-12-21 21:13:59] CMD OS Win32NT V6.1 Evals to False
[2009-12-21 21:13:59] CMD OS Win32NT V6.1 Evals to True


UAC is disabled on my workstation, and I'm right clicking and running the installer as Administrator.
Back to top
View user's profile Send private message AIM Address
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group