Red Gate forums :: View topic - Crash only during Profiling
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
ANTS Performance Profiler 5
ANTS Performance Profiler 5 forum

Crash only during Profiling

Search in ANTS Performance Profiler 5 forum
Post new topic   Reply to topic
Jump to:  
Author Message
heyneer



Joined: 18 Jun 2009
Posts: 1
Location: Montreal

PostPosted: Thu Jun 18, 2009 3:46 pm    Post subject: Crash only during Profiling Reply with quote

Hi,

I'm new to Ants Performance Profiler.

What should I do if my application crashes (throws Exceptions) only during profiling? These exceptions are not always the same...

I don't have that problem when I run my app in VS2008 or in release. I'm working on XP 64bits.

I have the problem with the version 4, and since this morning, with the version 5.0 also...

Thank you,

Eric
Back to top
View user's profile Send private message
StephenC



Joined: 15 Oct 2007
Posts: 315
Location: Cambridge

PostPosted: Thu Jun 18, 2009 4:46 pm    Post subject: Reply with quote

Hi,

can you try profiling the application at the method level (instead of line level). You can choose the profiling mode from the setup dialog.

Visiting the log file directory:
C:\Documents and Settings\YOUR.NAME\Local Settings\Application Data\Red Gate\ANTS Performance Profiler 5
and sending us any log files (support@red-gate.com) referencing this post would also be welcome.

Lastly if you are getting any stack trace exceptions if you could let us know what exceptions are being thrown that would also be very useful. Some screen shots would be fine - although it sounds like you aren't getting any stack traces? If this is the case then a mini-dump would be useful and I can provide instructions on how to do that if needed.

Stephen
Back to top
View user's profile Send private message
Chris.Allen



Joined: 12 Mar 2009
Posts: 547

PostPosted: Thu Jun 25, 2009 10:39 am    Post subject: Reply with quote

Hi there. I've got your support call now and I've been reading through the history. So- to start with, no, hopefully you didn't buy ANTS for nothing Smile We do get a number of crashes-under-profiling and they happen for a variety of reasons, most of which we solve and some of which we cannot. I'll endeavour to find out which one we have here but this will need a fair bit of debugging.

Firstly, please would you set the logging to full debug mode i.e. in the file

%userprofile%\Local Settings\Application Data\Red Gate\ANTS Performance Profiler 5\LoggingConfiguration.xml

change all the "tagged blocks" to look like the following:

<root>
<level value="DEBUG" />
<appender-ref ref="DefaultRGFile" />
</root>

<logger name="RedGate.Profiler.Engine">
<level value="DEBUG"/>
</logger>

<logger name="RedGate.Profiler.Logging">
<level value="DEBUG" />
</logger>

<logger name="RedGate.Profiler.Monitoring.PerformanceCounterFactory">
<leval value="DEBUG"/>
</logger>


(wierdly enough, you'll need to change instances of "leval" to "level" as well - sorry!)

Then please reproduce the problem and send us the resulting logfile (to support@red-gate.com).

We then may need to force and look at a dump of the crash (this is what we mean by a mini-dump- "mini" signifying that it is from the .NET runtime, I believe). We usually use windbg and I can drive this from a shared web session if you like.

But first, I think the debug logs would be a good start.

Cheers.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group