Red Gate forums :: View topic - HTTP Error 500.0 - Internal Server Error
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
ANTS Profiler Previous Versions
ANTS Profiler Previous Versions forum

HTTP Error 500.0 - Internal Server Error

Search in ANTS Profiler Previous Versions forum
Post new topic   Reply to topic
Jump to:  
Author Message
Seeker



Joined: 13 Mar 2009
Posts: 1

PostPosted: Fri Mar 13, 2009 8:30 am    Post subject: HTTP Error 500.0 - Internal Server Error Reply with quote

hi,
i have downloaded the trial, and trying to profile an ASP.net website on my local server but i get this error and when i press refresh the page keep on loading forever.
i tried using profiling on IIS and on unused port option and boht same results.

on a side note i am using Dot Tracer and i can profile with no problem at all

i am using Vista 64 bit
IIS 7


thanks in advanced
Back to top
View user's profile Send private message
Brian Donahue



Joined: 23 Aug 2004
Posts: 6580

PostPosted: Mon Mar 16, 2009 12:19 pm    Post subject: Reply with quote

Thanks for your post.

In order to profile IIS 7, a copy of the applicationHost.config is made and all of the extraneous configuration details are stripped out, then this configuration is used for the application pool started by ANTS Profiler. If this configuration is wrong, you could get a 500 internal server error. What you should then do is check the Windows event viewer and look for an error entry in the Application log from a source of "hostablewebcore". This should have detailed information about the configuration failure.

ANTS Profiler 4.3 also does a much better job of setting up the configuration than 4.0 or 4.1. If you already have v4.3, you may want to check for this condition that can be caused by ANTS Profiler that permanently affects your IIS.
Back to top
View user's profile Send private message
paulsmith



Joined: 23 Apr 2009
Posts: 8
Location: Durham

PostPosted: Thu Apr 23, 2009 3:55 pm    Post subject: Reply with quote

Hi

I'm having the same problem with Vista 64bit and IIS7 however the application log is less than helpful....

- <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
- <System>
<Provider Name="HostableWebCore" />
<EventID Qualifiers="49152">2299</EventID>
<Level>2</Level>
<Task>0</Task>
<Keywords>0x80000000000000</Keywords>
<TimeCreated SystemTime="2009-04-23T14:45:13.000Z" />
<EventRecordID>4083</EventRecordID>
<Channel>Application</Channel>
<Computer>CC-101.communicatorcorp.com</Computer>
<Security />
</System>
- <EventData>
<Data>An error message detailing the cause of this specific request failure can be found in the application event log of the web server. Please review this log entry to discover what caused this error to occur.</Data>
<Binary>05400080</Binary>
</EventData>
</Event>

It simply points me back to itself!

Is there a way to get this working?

Thanks
Back to top
View user's profile Send private message
T.Fitzgerald



Joined: 28 Apr 2009
Posts: 1

PostPosted: Tue Apr 28, 2009 5:42 pm    Post subject: Reply with quote

I'm having the same problem in the same environment (IIS7, Vista64). The memory profiler runs fine, as does the performance profiler when it runs against a web application hosted in Cassini. The problem is specific to IIS7 and occurs no matter how simple (or complex) the website is that I am trying to profile. The internal server error occurs regardless of whether I profile on the original port or on an unused port.

The hostablewebcore event log entry just points back to itself and is no help. There is no "Environment" registry value to delete.

I've unsuccessfully tried a number of access-control and security-related workarounds, including temporarily disabling my firewall and all anti-virus software. Here's a rundown of what customer service suggested and what I tried.

Quote:
- Run the Windows Registry Editor (regedit.exe)
- Navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\W3SVC- Delete the value called "Environment"


There wasn't an Environment value in the registry, nothing to delete...

Quote:
What you may want to do is make sure that the account ('Network Service', by default') running your application pool has permissions to the "Temporary ASP .NET Files" folder, including subdirectories. The hidden cause of this problem, when it happens, is that your app pool's account also needs full control over the "c:\windows\temp" folder. (http://social.msdn.microsoft.com/Forums/en-US/tfswebaccess/thread/c43238f8-a2ef-4503-aec6-fbf46870d8a4/)


I created an ACL that explicitly granted the app-pool account (NETWORK SERVICE) full access to the following folders (and their subfolders): c:\windows\Microsoft.Net\Framework\ v2.0.50727\Temporary ASP.NET Files, c:\windows\temp, and %temp%. No change.

Quote:
You may also find your 'Network Service' account no longer has the permissions necessary to run sites, after installing Ants Profiler. To temporarily fix the problem run the App Pool under the 'Local System' account.


I changed the app pool to run under the Local System account and then went back and rechecked the ACLs to ensure that SYSTEM had full access to the folders used by ASP.NET. No change.

Quote:
You could try using the ASPNET_REGIIS.exe utility that comes with the .NET Framework. It can automatically assign all the permissions for ASP .NET to an account, including the metabase and temporary files folder. You can run this from the command prompt:

%systemroot%\microsoft.net\framework\v2.0.50727\aspnet_regiis -ga "NT Authority\Network Service"


I restored the App-pool account to Network Service and ran the above command. It completed successfully, but there was no change.

Quote:
We also think that what may have happened to your IIS installation is that some files and folders may have the ACLs set up explicitly for the SYSTEM account. Although this has never happened before, you may want to try emptying out your .NET Framework's "Temporary ASP .NET Files" folder and see if that gets it working for you.


I cleared out the temporary asp.net files folder, recycled the app pool, restarted IIS. No change

I can't figure out where the temporary copy of applicationHost.config gets created either. A post in another thread (http://www.red-gate.com/messageboard/viewtopic.php?t=8574) mentioned that the local copy of applicationHost.config generated by the profiler before starting a profiling session on an IIS-hosted website is called tmp{something}.config and that this temporary config file is created in %USERPROFILE%\AppData\Local\Red Gate\ANTS Performance Profiler 4. That temporary config file copy never gets created on my machine, and I know that the profiler has write access to the appdata\local\ANTS Performance Profiler 4 folder because it creates a logfile in that folder every time it runs. (Those logfiles don't contain any additional clues or stack traces either.) I also tested to see if I could manually make a copy of applicationHost.config file, and that worked OK, so there are no file-protection problems on that config file or on its containing folder.
Back to top
View user's profile Send private message
jMarkP



Joined: 08 May 2009
Posts: 1
Location: York, UK

PostPosted: Fri May 08, 2009 11:39 am    Post subject: Reply with quote

I had exactly the same problems as described here (including T.Fitzgerald's latest post) in both 4.1 and 4.3.

I managed to get it working by choosing 'Hosted in web development server' instead of 'hosted in IIS'. It now profiles perfectly.

I'm working on an ASP.NET app, using .Net 2.0 with IIS7 and Vista 64bit.

Hope that helps others.
Back to top
View user's profile Send private message
Chris.Allen



Joined: 12 Mar 2009
Posts: 546

PostPosted: Mon May 11, 2009 12:12 pm    Post subject: Reply with quote

Sorry for all these problems guys. As some of you have found out - profiling under the development web server usually works much better (the web dev environment is much simpler than IIS- no impersonation, no SSL etc) but we still haven't got to the bottom of the real problem here although it is very likely to do with how applicationHost.config is dealt with). So, my colleague Brian found a way of bypassing this which seems to work well in some case.

Debugging from the top.

Are you using <= .NET 1.1?

Also, is your app pool configured in Integrated Pipeline mode?

We don't seem to do so well with the early frameworks or integrated
pipeline. If its possible, please try a different configuration (e.g. .NET
2.0, classic mode). Otherwise, the workaround is to use a console app that
uses HostableWebCore and treats the applicationHost.config file differently
to ANTS (so if this works, we know that this is the cause of the problem).

Please download it from here

(if you are using .NET 1.1)

ftp://support.red-gate.com/Patches/ANTS_Profiler/ANTSApplicationHost11.zip

(otherwise)

ftp://support.red-gate.com/Patches/ANTS_Profiler/ANTSApplicationHost.zip

The original post was here:

http://www.red-gate.com/MessageBoard/viewtopic.php?t=8164&highlight=antsappl
icationhost

ReadMe.txt included in zip file.
Back to top
View user's profile Send private message
Chris.Allen



Joined: 12 Mar 2009
Posts: 546

PostPosted: Wed May 20, 2009 7:40 pm    Post subject: Reply with quote

We may, finally, have a definitive answer:

On a 64-bit OS, profiling a web app when IIS is set to 32-bit fails. You get a HTTP 500 internal server error. We think it's loading the 64-bit core into a 32-bit process.

To set IIS to 32-bit mode, run the VBscript command as described here:
http://support.microsoft.com/kb/894435
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group