Red Gate forums :: View topic - Waiting for connection
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
ANTS Profiler Previous Versions
ANTS Profiler Previous Versions forum

Waiting for connection

Search in ANTS Profiler Previous Versions forum
Post new topic   Reply to topic
Jump to:  
Author Message
Saran78



Joined: 18 Nov 2008
Posts: 1

PostPosted: Wed Nov 19, 2008 12:56 am    Post subject: Waiting for connection Reply with quote

Hi,

We have the ANTS 3.2 licensed version.
Am trying to profile WCF service. I follow the Project Wizard to start the profiling for .NET Windows service. When I click Finsh in the wizard, the Profiler is showing "Waiting for Connection" message. It does't start the service... nothing happens after that....

(I have deployed the debug verion of my assembly(and PDB file) in the server.)

Am I missing something here.

Thanks in advance
Saravana
Back to top
View user's profile Send private message
Brian Donahue



Joined: 23 Aug 2004
Posts: 6648

PostPosted: Fri Nov 21, 2008 4:46 pm    Post subject: Reply with quote

I'm sorry I don't have any advice except to say it's nothing to do with the PDB. If you are left "waiting for a connection" it means that the service did not run any managed .NET code. If the service had failed to start, ANTS Profiler would have left an error message, so I assume that the service had started and is running.

You can tell if the .NET runtime had loaded by examining the process to see if it loads mscorlib.dll. If this dll is not loaded by your service, you are not running managed code, and consequently the ANTS Profiler COM dll does not load into your system 9RedGate.Profiler.Core2.dll).

The other possibility is that the Core2 dll couldn't load or had crashed. In the former case, an application event log error entry saying "couldn't coCreate Profiler" would appear.
Back to top
View user's profile Send private message
tong



Joined: 23 Apr 2009
Posts: 2

PostPosted: Thu Apr 23, 2009 11:28 pm    Post subject: Reply with quote

Was this tested? I mean I have the same situation, trying to profile Window Service hosted WCF services. But the profiler always hangs on "Waiting for connection...". The previously-running service was stopped by the profiler but stayed stopped.

Any suggestion on what might went wrong?
Back to top
View user's profile Send private message
Chris.Allen



Joined: 12 Mar 2009
Posts: 589

PostPosted: Fri Apr 24, 2009 3:35 pm    Post subject: ANTS 3 profiling WCF service, Connection waiting... Reply with quote

Yes, this has been tested and it does work. I think we'd need to see some logs to find out the real cause of the problem.Can you set up logging as per this article please:

http://www.red-gate.com/supportcenter/Content.aspx?p=ANTS%20Profiler&c=knowledgebase\ANTS_Profiler\KB200701000002.htm

(In summary, create a 'logs' folder in the profiler folder and restart the ANTS 3 service, and reproduce the problem)
Back to top
View user's profile Send private message
tong



Joined: 23 Apr 2009
Posts: 2

PostPosted: Fri Apr 24, 2009 5:06 pm    Post subject: Reply with quote

Here's what the log says:

4/24/2009 11:50:53 AM ANTSProfilerLog initialized
4/24/2009 11:50:53 AM PID = 4140
4/24/2009 11:50:53 AM Log file name = ANTSProfilerLog4140.txt
4/24/2009 11:50:53 AM OS version = Microsoft Windows NT 5.1.2600 Service Pack 3
4/24/2009 11:50:53 AM Machine name = xxx
4/24/2009 11:50:53 AM User name = yyy
4/24/2009 11:50:53 AM PARAMHOST - Listening on port 8084
4/24/2009 11:50:53 AM PARAMHOST - Listening on port 8084, channel registered
4/24/2009 11:50:54 AM EditProjectClosingWizard start
4/24/2009 11:50:54 AM EditProjectClosingWizard start
4/24/2009 11:50:54 AM Couldn't find WebDev (2008) at: C:\Program Files\Common Files\Microsoft Shared\DevServer\9.0\WebDev.WebServer.EXE
4/24/2009 11:50:54 AM About to show wizard
4/24/2009 11:51:02 AM Wizard dialog returned
4/24/2009 11:51:05 AM UI Start profiling
4/24/2009 11:51:05 AM ENGINE - Core2.dll found in regisry
4/24/2009 11:51:06 AM ENGINE Start profiling performance (fast mode) of windows service WCFTest
4/24/2009 11:51:06 AM ENGINE The profiler is enabled
4/24/2009 11:51:06 AM TRANSFER - Waiting for pipe connection from core
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group