Red Gate forums :: View topic - Mailbox size displayed as ‘Unavailable’ for all users.
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
Exchange Server Archiver
Exchange Server Archiver forum

Mailbox size displayed as ‘Unavailable’ for all users.

Search in Exchange Server Archiver forum
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.
Jump to:  
Author Message
Matthew Flatt



Joined: 15 Jan 2008
Posts: 253

PostPosted: Thu Apr 23, 2009 10:20 am    Post subject: Mailbox size displayed as ‘Unavailable’ for all users. Reply with quote

When opening the ESA Admin Console and expanding the list of users you may see ‘Unavailable’ displayed for the Exchange mailbox size.

If you installed the Microsoft Exchange Server MAPI Client and Collaboration Data Objects 1.2.1 component onto your machine(s) running the Archive Service and User Archive Access Service you may see the following message logged into the Admin Console:

ArchiveService
COMException logging on to Exchange Server: System.Runtime.InteropServices.COMException (0x8004010F): Error in IMsgServiceAdmin::CreateMsgService: MAPI_E_NOT_FOUND
Error: This information service is not installed on your computer. To install it, use the Mail And Fax icon in the Control Panel.

If this message occurs, please reboot the machine(s) as even though the MAPI CDO installation does not prompt you, it is often required.

On a solely Exchange 2007/Outlook 2007 environment with the Microsoft Exchange Server MAPI Client and Collaboration Data Objects 1.2.1 component installed onto the machine running the Archive Service and User Archive Access Service, you may also see the following message:

MAILBOX
Cannot open mailbox 'user@domain.com’.
Ensure that:
- the Archive Service is running as a domain user with the required permissions (for more details, see http://www.red-gate.com/ESA/1.0?i=9420 )
- the Microsoft Exchange Information Store service on mailboxserver.domain.com is running

This message can occur because the MAPI CDO download communicates with Outlook 2003 MAPI which requires public folders.

There are two possible ways to work around this problem.

1. Install Outlook 2007 onto the machine(s) running the Archive and User Archive Access services. This then installs an updated MAPI version which does not require public folders.

2. Install public folder databases into your Exchange 2007 servers.
_________________
Matthew Flatt
Test Engineer, HyperBac
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies. All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group