Red Gate forums :: View topic - Error starting profiler
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
ANTS Profiler Previous Versions
ANTS Profiler Previous Versions forum

Error starting profiler

Search in ANTS Profiler Previous Versions forum
Post new topic   Reply to topic
Jump to:  
Author Message
sgraham



Joined: 14 Apr 2009
Posts: 4

PostPosted: Tue Apr 14, 2009 5:36 pm    Post subject: Error starting profiler Reply with quote

I'm trying to run the Memory Profiler on an ASP.NET 3.5 web application. When I start the profiler, it brings up an IE window for my application, which then sends me to another login application and then back to the one i want to profile.

In the bottom left of the profiler i see "Waiting for connection", and whenever i try to take a snapshot or close the IE window, i get an error message saying "The web application xxxx has not loaded the .NET Framework. Please check that xxxx is an ASP.NET web application. Please note that accessing cached web pages will not load the .NET Framework."

I've tried running through both IIS and Cassini to no avail. I'm running under the SYSTEM account locally and added the 2 environment variables from this article with no luck: http://www.red-gate.com/supportcenter/Content.aspx?p=ANTS%20Profiler&c=knowledgebase\ANTS_Profiler\KB200708000140.htm

Here is some extra information if it helps:
.NET version - 3.5 (2.0 in IIS)
IIS version - 5.1
user - SYSTEM
operating system - WinXP SP2
ANTS version - 4.1.0.45

Please let me know if you can help or if you need any other information.

Thanks,
Sean
Back to top
View user's profile Send private message
StephenC



Joined: 15 Oct 2007
Posts: 315
Location: Cambridge

PostPosted: Tue Apr 14, 2009 7:14 pm    Post subject: Reply with quote

Hi Sean,

sorry for the trouble you are having. Would you mind trying an early access build of our upcoming V5 Memory Profiler and let us know if it solves the issue you are having?

The early access forum is here (build 667):
http://www.red-gate.com/messageboard/viewforum.php?f=92

Kind regards,

Stephen
Back to top
View user's profile Send private message
sgraham



Joined: 14 Apr 2009
Posts: 4

PostPosted: Tue Apr 14, 2009 7:35 pm    Post subject: V5 Reply with quote

I installed the V5 profiler and tried profiling my application. When I start it, IE brings up the site but the profiler still has a big bubble that says "Starting Application". I can't take a snapshot either. When I click that button nothing happens.
Back to top
View user's profile Send private message
sgraham



Joined: 14 Apr 2009
Posts: 4

PostPosted: Tue Apr 14, 2009 7:39 pm    Post subject: logs Reply with quote

Here is the contents of the log file that was generated:

14 Apr 2009 13:30:40.065 [1] INFO RedGate.Profiler.Logging.LogService - Starting new ANTS Memory Profiler 5 session
14 Apr 2009 13:30:40.065 [1] INFO RedGate.Profiler.Logging.LogService - Assembly version: 5.0.0.667
14 Apr 2009 13:30:44.939 [1] WARN RedGate.Profiler.OS.Local.LocalWindowsVersionInspector - Detected Windows version: Windows XP Professional (5.1 32-bit)
14 Apr 2009 13:30:44.939 [1] WARN RedGate.Profiler.IISSupport.Local.LocalIisInspector - IIS is supported on installed OS version
14 Apr 2009 13:30:44.986 [1] WARN RedGate.Profiler.IISSupport.Local.LocalIisInspector - Result of check to see if inetinfo.exe running: True
14 Apr 2009 13:30:44.986 [1] WARN RedGate.Profiler.IISSupport.Local.LocalIisInspector - IIS is running.
14 Apr 2009 13:30:44.986 [1] WARN RedGate.Profiler.IISSupport.Local.LocalIisInspector - Result of check to see if inetinfo.exe running: True
14 Apr 2009 13:30:44.986 [1] WARN RedGate.Profiler.IISSupport.Local.LocalIisInspector - IIS is running.
14 Apr 2009 13:30:44.986 [1] WARN RedGate.Profiler.IISSupport.Local.LocalIisInspector - IIS is enabled.
14 Apr 2009 13:30:44.986 [1] WARN RedGate.Profiler.IISSupport.Local.LocalIisInspector - Successfully detected IIS installation: IIS 5.1 (Auto-detected)
14 Apr 2009 13:30:44.986 [1] WARN RedGate.Profiler.IISSupport.Local.LocalIisInspector - IIS is installed
14 Apr 2009 13:30:48.345 [21] WARN RedGate.Profiler.IISSupport.Local.LocalIisInspector - IIS is installed
14 Apr 2009 13:30:48.345 [21] WARN RedGate.Profiler.IISSupport.Local.LocalIisInspector - IIS is installed
14 Apr 2009 13:30:48.361 [21] WARN RedGate.Profiler.IISSupport.Local.LocalIisInspector - IIS is installed
14 Apr 2009 13:30:50.032 [1] WARN RedGate.Profiler.IISSupport.Local.LocalIisInspector - IIS is installed
14 Apr 2009 13:30:50.048 [1] WARN RedGate.Profiler.IISSupport.Local.LocalIisInspector - IIS is installed
14 Apr 2009 13:30:50.204 [21] WARN RedGate.Profiler.IISSupport.Local.LocalIisInspector - IIS is installed
14 Apr 2009 13:30:50.798 [21] WARN RedGate.Profiler.IISSupport.Local.LocalIisInspector - IIS is installed
14 Apr 2009 13:30:51.173 [21] WARN RedGate.Profiler.IISSupport.Local.LocalIisInspector - IIS is installed
14 Apr 2009 13:31:01.531 [1] WARN RedGate.Profiler.IISSupport.Local.LocalIisInspector - IIS is installed
14 Apr 2009 13:31:01.546 [1] WARN RedGate.Profiler.IISSupport.Local.LocalIisInspector - IIS is installed
14 Apr 2009 13:31:01.546 [1] WARN RedGate.Profiler.IISSupport.Local.LocalIisInspector - IIS is installed
14 Apr 2009 13:31:01.546 [1] WARN RedGate.Profiler.IISSupport.Local.LocalIisInspector - IIS is installed
14 Apr 2009 13:31:01.890 [ConfigurableThreadPool thread] WARN RedGate.Profiler.IISSupport.Local.LocalIisInspector - IIS is installed
14 Apr 2009 13:31:08.920 [ConfigurableThreadPool thread] WARN RedGate.Profiler.IISSupport.Local.LocalIisInspector - IIS is installed
14 Apr 2009 13:31:16.857 [21] WARN RedGate.Profiler.IISSupport.Local.LocalIisInspector - IIS is installed
14 Apr 2009 13:31:16.857 [21] WARN RedGate.Profiler.IISSupport.Local.LocalIisInspector - IIS is installed
14 Apr 2009 13:31:17.310 [21] WARN RedGate.Memory.Controller.Settings.MemoryProfilerSettings - Exception whilst loading MemoryProfilerSettings.xml...
14 Apr 2009 13:31:17.310 [21] WARN RedGate.Memory.Controller.Settings.MemoryProfilerSettings - Could not find file 'C:\Documents and Settings\grahamst\Local Settings\Application Data\Red Gate\ANTS Memory Profiler 5\MemoryProfilerSettings.xml'.
14 Apr 2009 13:31:17.310 [21] WARN RedGate.Memory.Controller.Settings.MemoryProfilerSettings - System.IO.FileNotFoundException
14 Apr 2009 13:31:17.325 [21] WARN RedGate.Memory.Controller.Settings.MemoryProfilerSettings - at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
at System.IO.FileStream.Init(String path, FileMode mode, FileAccess access, Int32 rights, Boolean useRights, FileShare share, Int32 bufferSize, FileOptions options, SECURITY_ATTRIBUTES secAttrs, String msgPath, Boolean bFromProxy)
at System.IO.FileStream..ctor(String path, FileMode mode, FileAccess access, FileShare share)
at RedGate.Profiler.XmlPersist.XmlObjectLoader.Load(String filename)
at RedGate.Memory.Controller.Settings.MemoryProfilerSettings.a()
14 Apr 2009 13:31:17.341 [ConfigurableThreadPool thread] WARN RedGate.Profiler.Engine.Startup.Sessions.IISSession - Couldn't find w3wp.exe in C:\WINDOWS\system32\inetsrv
Back to top
View user's profile Send private message
StephenC



Joined: 15 Oct 2007
Posts: 315
Location: Cambridge

PostPosted: Wed Apr 15, 2009 9:50 am    Post subject: Reply with quote

Hi,

if you follow the instructions in the article that you mentioned but add this for V5 and let me know how it goes:

[ANTS Memory Profiler version 5.x]
Name: COR_PROFILER Value: {D60F7519-2600-4865-8AC1-C621C9CE41A2}

Thanks,

Stephen
Back to top
View user's profile Send private message
sgraham



Joined: 14 Apr 2009
Posts: 4

PostPosted: Wed Apr 15, 2009 2:02 pm    Post subject: error Reply with quote

Now i get the following error when i try to start profiling:

Could not start IIS.
RedGate.Profiler.Engine.Exceptions.CannotStartSessionException
at eV.Launch()
at RedGate.Memory.Controller.Session.ProfilerSession.i()

Caused by:

Could not start IIS.
RedGate.Profiler.Engine.Exceptions.CannotStartIisSessionException
at fa.PerformLaunch()
at eV.Launch()

Caused by:

Requested Service not found
System.Runtime.Remoting.RemotingException
stack trace:
at System.Runtime.Remoting.Channels.BinaryServerFormatterSink.ProcessMessage(IServerChannelSinkStack sinkStack, IMessage requestMsg, ITransportHeaders requestHeaders, Stream requestStream, IMessage& responseMsg, ITransportHeaders& responseHeaders, Stream& responseStream)
rethrown at [0]:
at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
at RedGate.Profiler.Engine.Startup.IProxyStatusEventTarget.ServiceStatusChanged(Object sender, StatusEventArgs e)
at ez.b()
at ez.StartProfilingIIS(String currentUserName, String subprocessVariableValue)
at RedGate.Profiler.Engine.Startup.IIS.IISStarter`1.StartProfilingIIS(String currentUserName, String subprocessVariableValue)
at System.Runtime.Remoting.Messaging.StackBuilderSink._PrivateProcessMessage(IntPtr md, Object[] args, Object server, Int32 methodPtr, Boolean fExecuteInContext, Object[]& outArgs)
at System.Runtime.Remoting.Messaging.StackBuilderSink.PrivateProcessMessage(RuntimeMethodHandle md, Object[] args, Object server, Int32 methodPtr, Boolean fExecuteInContext, Object[]& outArgs)
at System.Runtime.Remoting.Messaging.StackBuilderSink.SyncProcessMessage(IMessage msg, Int32 methodPtr, Boolean fExecuteInContext)
rethrown at [1]:
at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
at RedGate.Profiler.Engine.Startup.IIISActuator`1.StartProfilingIIS(String currentUserName, String subprocessVariableValue)
at fa.PerformLaunch()
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group