Red Gate forums :: View topic - Installation fails-MSI returned failure code InstallFailure
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
SQL Comparison SDK Previous Versions
SQL Comparison SDK Previous Versions forum

Installation fails-MSI returned failure code InstallFailure

Search in SQL Comparison SDK Previous Versions forum
Post new topic   Reply to topic
Jump to:  
Author Message
meklembl



Joined: 24 Aug 2007
Posts: 89
Location: Solon, OH, USA

PostPosted: Wed Apr 08, 2009 2:01 pm    Post subject: Installation fails-MSI returned failure code InstallFailure Reply with quote

Installation fails-MSI returned failure code InstallFailure (1603)

Locally on my workstation, I attempted to run the install from SQL Toolbelt and from the separate download of SQL_Comparison_SDK_8.0.0.105.exe. At least in both case the error was the same.
_________________
Larry M
Cleveland, OH USA
Back to top
View user's profile Send private message
Brian Donahue



Joined: 23 Aug 2004
Posts: 6646

PostPosted: Wed Apr 08, 2009 5:53 pm    Post subject: Reply with quote

Hi,

Unbfortunately "1603" is a generic failure code. You can access the installation log by clicking the icon in the installer's toolbar and selecting "view log". If you have any problem interpreting the information in the log, I'd recommend emailing it to support@red-gate.com with an explanation about the failure message you're getting.
Back to top
View user's profile Send private message
meklembl



Joined: 24 Aug 2007
Posts: 89
Location: Solon, OH, USA

PostPosted: Wed Apr 08, 2009 5:59 pm    Post subject: Reply with quote

Forwarded the log files to support.
_________________
Larry M
Cleveland, OH USA
Back to top
View user's profile Send private message
Brian Donahue



Joined: 23 Aug 2004
Posts: 6646

PostPosted: Wed Apr 08, 2009 6:40 pm    Post subject: Reply with quote

Thanks. This looks like the same issue we've seen twice already today where the installation fails because you've redirected your "My Documents" folder to a network share. From the log it does appear that the failure is to create the user options file so that the references are correct when you first build a project.

We will see if we can get this fixed, but in the meantime, using a folder on local disk for "My Documents" should let it do its' magic.
Back to top
View user's profile Send private message
AvonWyss



Joined: 29 Oct 2008
Posts: 30

PostPosted: Tue May 19, 2009 12:31 pm    Post subject: Reply with quote

Same problem here, and I also have My Documents on a network share (and Vista x64 as platform, if that makes any difference). Interesting enough, all the other applications in the Toolbelt install fine.
Back to top
View user's profile Send private message
Brian Donahue



Joined: 23 Aug 2004
Posts: 6646

PostPosted: Tue May 19, 2009 6:31 pm    Post subject: Reply with quote

SQL Comparison SDK's installer is unique in that, once it copies all of the example projects to the My Documents folder, it tries to modify the .csproj and .vbproj files so that the assembly reference paths reflect the location where the SDK's assemblies are copied.

For reasons I'm unaware of, the ExecuteXml function fails over network shares and mapped drives. It's not a .NET managed code policy problem as was my first suspicion...

Anyway, we are looking to get this fixed in the next release.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group