Red Gate forums :: View topic - SQL Comparison SDK 8 Install fails
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
SQL Comparison SDK Previous Versions
SQL Comparison SDK Previous Versions forum

SQL Comparison SDK 8 Install fails

Search in SQL Comparison SDK Previous Versions forum
Post new topic   Reply to topic
Jump to:  
Author Message
markaok1



Joined: 20 Mar 2009
Posts: 11
Location: Omaha, Nebraska

PostPosted: Tue Apr 07, 2009 4:45 pm    Post subject: SQL Comparison SDK 8 Install fails Reply with quote

I've tried using the install from evaluation copy of SQL Toolbelt and the separate download link from the other post in this forum.


Here's the error from the Application Event Viewer:
Product: SQL Comparison SDK 8 -- Error 25531. Failed to open XML file \\OurServer\MyUserName\SQL Comparison SDK 8 Samples\Automating SQL Compare\C#\SQLCompareCodeSnippets.csproj, system error: -2147024891

If Version 8 isn't working is there a way I can download version 7? We're doing a Proof of Concept for automating some db work.

Thanks!
MarkA
Back to top
View user's profile Send private message
Waldo2k2



Joined: 21 Aug 2008
Posts: 11

PostPosted: Tue Apr 07, 2009 5:13 pm    Post subject: Reply with quote

Mark,

I had no problems getting the SDK installed using the SQLToolbelt installer. Though in my case I ran the setup from a local drive, and installed to a local drive.
It looks like perhaps you're running the installer from a network drive, or installing to a network drive? Perhaps that is causing the problem.
Back to top
View user's profile Send private message
markaok1



Joined: 20 Mar 2009
Posts: 11
Location: Omaha, Nebraska

PostPosted: Tue Apr 07, 2009 7:07 pm    Post subject: Reply with quote

I'm running locally and installing locally. The reference to the network path is where 'My Documents' is mapped. Not sure why putting out some sample files is making the install fail...

Thanks for your quick reply.
MarkA
Back to top
View user's profile Send private message
Waldo2k2



Joined: 21 Aug 2008
Posts: 11

PostPosted: Tue Apr 07, 2009 7:28 pm    Post subject: Reply with quote

Well, it's possible the path to your my documents has nothing to do with it. Do you have msxml3 or higher installed on your system?
Back to top
View user's profile Send private message
markaok1



Joined: 20 Mar 2009
Posts: 11
Location: Omaha, Nebraska

PostPosted: Tue Apr 07, 2009 8:13 pm    Post subject: Reply with quote

I've got msxml 6.0. I've got an email into Redgate on this...

Thanks for all your suggestions...
MarkA
Back to top
View user's profile Send private message
Brian Donahue



Joined: 23 Aug 2004
Posts: 6678

PostPosted: Wed Apr 08, 2009 9:59 am    Post subject: Reply with quote

Hi,

For sure, this is a security restriction. When opening VS projects from a network share, the intranet zone security will take effect and cause problems like this, I'd imagine. I don't think that the zone security takes into consideration that you use folder redirection in your profile.
Back to top
View user's profile Send private message
markaok1



Joined: 20 Mar 2009
Posts: 11
Location: Omaha, Nebraska

PostPosted: Wed Apr 15, 2009 3:27 am    Post subject: Reply with quote

Had to have a domain admin log in and install. Thanks for pointing me in the right direction.
Thanks!
MarkA
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group