Red Gate forums :: View topic - ANTS Profiler giving error while starting profiling
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
ANTS Profiler Previous Versions
ANTS Profiler Previous Versions forum

ANTS Profiler giving error while starting profiling

Search in ANTS Profiler Previous Versions forum
Post new topic   Reply to topic
Jump to:  
Author Message
chetansawant79



Joined: 03 Apr 2009
Posts: 2

PostPosted: Fri Apr 03, 2009 12:02 pm    Post subject: ANTS Profiler giving error while starting profiling Reply with quote

Hi,

I want to check the performance of my site. I installed ANTS Profiler 4.3 and set the setting of it. But when I click on Start Profiling it gives me error. When I clicked on Show details it was having 3 errors:-
1) Could not launch the task to be profiled.
2) Could not start IIS.
3) Type 'bz' in Assembly 'RedGate.Profiler.Engine, Version=4.3.0.198, Culture=netural, PublicTokenKey=7f465a1c156d4d57' is not marked as serializable.

I could not understand this error.
Can anyone please help me out to user ANTS Profiler?

Thanks,
Chetan.
Back to top
View user's profile Send private message
Brian Donahue



Joined: 23 Aug 2004
Posts: 6673

PostPosted: Mon Apr 06, 2009 2:39 pm    Post subject: Reply with quote

Hi and thanks for your post. ANTS Profiler has thrown some sort of internal exception type and can't display the information because it's not "serializable" -- so there are two issues here, one is that the IIS startup has failed and the other is that the exception details can't be displayed because the exception class defined in the ANTS Profiler code is not serializable.

I would concentrate on the first failure and try to work out why the IIS start had failed.

What version of IIS are you profiling, what is the URL that you have told it to profile, and are there any events in the application log when ANTS Profiler fails to start IIS?
Back to top
View user's profile Send private message
chetansawant79



Joined: 03 Apr 2009
Posts: 2

PostPosted: Tue Apr 07, 2009 7:16 am    Post subject: Reply with quote

Hi Brian,

I am using IIS 6 and also checked the event in application log but there is no error associated with ANTS Profiler. I using localhost URL.

Thanks,
Chetan.
Back to top
View user's profile Send private message
Brian Donahue



Joined: 23 Aug 2004
Posts: 6673

PostPosted: Tue Apr 07, 2009 9:32 am    Post subject: Reply with quote

I can see a few possibilities. The most likely is that the ANTS Performance Profiler 4 Service could not be started. If that is the case, the reason may be in the ANTS Profiler logs that you find in %userprofile%\Local Settings\Application Data\Red Gate\ANTS Performance Profiler 4\

The only other situation that causes this exception is if you are in IIS 5 isolation mode and ANTS is failing to restart IIS.

Hopefully that's enough to figure out what the problem is.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group