Red Gate forums :: View topic - Type NVarchar(max) not supported in the target db version
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
SQL Packager 6
SQL Packager 6 forum

Type NVarchar(max) not supported in the target db version

Search in SQL Packager 6 forum
Post new topic   Reply to topic
Jump to:  
Author Message
CodeDreamer68



Joined: 25 Mar 2009
Posts: 3

PostPosted: Wed Mar 25, 2009 5:09 pm    Post subject: Type NVarchar(max) not supported in the target db version Reply with quote

I get this warning message...

The type NVarchar(max) on object [dbo].[CPM_Projects].[ProjectDescr] is not supported in the target database version.

How do I change the target database version to SQL 2005?
Back to top
View user's profile Send private message
Brian Donahue



Joined: 23 Aug 2004
Posts: 6581

PostPosted: Fri Mar 27, 2009 7:25 pm    Post subject: Reply with quote

Hi Charles,

SQL Packager automatically selects the T-SQL formatting based on the version of the target server in an upgrade package. The SQL version can't be chosen manually. I hope that we can put the option in for a future version of SQL Packager, but for now, you must put the target database on a SQL Server 2005 in order to get a SQL 2005-formatted script that supports SQL 2005 datatypes.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group