Red Gate forums :: View topic - Data is not getting inserted into the database
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
ANTS Load
ANTS Load forum

Data is not getting inserted into the database

Search in ANTS Load forum
This forum is locked: you cannot post, reply to, or edit topics.   This topic is locked: you cannot edit posts or make replies.
Jump to:  
Author Message
srajoli



Joined: 19 Jan 2007
Posts: 2

PostPosted: Fri Jan 19, 2007 4:07 pm    Post subject: Data is not getting inserted into the database Reply with quote

Hi,

I am new to this ANTS tool. Yesterday i installed trail version and started working on it. The page i am testing is a page to submit data. I recorded a script and then ran it for 5 virtual users. Load test is passed. but when i went ot the database (SQl server) and checked it, it inserted the data only once when i submitted the data while recorded the script. But it didn't insert data, whne i ran it for 5 virtual users. please help me........

-Sireesha
Back to top
View user's profile Send private message
Brian Donahue



Joined: 23 Aug 2004
Posts: 6677

PostPosted: Sat Jan 20, 2007 9:48 pm    Post subject: Reply with quote

Hello Sireesha,

This is a very common issue with ANTS Load. The solutions are various, since ANTS Load only sends simple requests to a web server and has no interaction at all with the application apart from that, we have to assume that the test is not successful and find a way to troubleshoot it. Since you do have one successful insert, the test script must be correct, but not able to be run multiple times. Some common issues:
  • The test user needs to login/logout in the script. Try making sure that the virtual user logs out at the end of the test script.
  • There is some dynamic data that needs to be grabbed from the response page in order to be posted back to the server. ANTS Load, if you use the recorded script, is always posting the same data. This may work once, but not in subsequent attempts.
  • The test may be marked as successful, rather than failed, because of custom error pages. If server errors are resulting in HTTP 200 OK instead of an HTTP 4xx/5xx error, then the only way to find any errors is to use me.logtofile(WebClient.HttpResponse.Content) and having a look at the antstracelog.txt file.

I'm sorry there is no easy answer here -- since almost all web applications are bespoke, the answer depends on how the web application is designed.
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies. All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group