Red Gate forums :: View topic - SQL Compare hangs at "Reading object text"
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
SQL Compare 10
SQL Compare 10 forum

SQL Compare hangs at "Reading object text"

Search in SQL Compare 10 forum
Post new topic   Reply to topic
Jump to:  
Author Message
msurasky



Joined: 13 Mar 2014
Posts: 7
Location: Canada

PostPosted: Fri Apr 25, 2014 8:48 pm    Post subject: SQL Compare hangs at "Reading object text" Reply with quote

Hi all,

I am trying to generate a Snapshot of a database located in a remote location. I am runing SQL Compare 10.3.

I have verified that SQL Compare has no trouble in seeing that server (and the database). The tool can successfully retrieve the list of the databases on the SQL Server Instance when connecting to it.

Having said that, either when trying to run a comparison project (or when generating a snapshot) the tool is stuck at a step called "Reading object text" (which in the case of the snapshot is around 29% for my database).

I let it run for an hour and it has not been progressed by a single percentage so at this point I believe the process is stuck. I have tried twice and in both cases it got stuck at the precise same location.

I have a print-screen of the exact state where the tool get stuck but I believe there is no way to add attachments to post here.

I believe this is a bug that for some reason only occur under this circumstance but even when the behavior (the error) is consistently happening, I can't figure out why it happens or what should I do to fix it.

If anybody in the forum supports that tool (or has seen the error before) please let me know what you think I should be doing in order to troubleshoot.

I can provide logs or any details you need about my environment.

Regards,
Back to top
View user's profile Send private message
eddie davis



Joined: 14 Jun 2006
Posts: 925
Location: Red Gate Software

PostPosted: Mon Apr 28, 2014 11:27 am    Post subject: Reply with quote

Thank you for your forum post.

A support call has been created for you HERE.

Please update the call with a copy of the SQL Compare log file from when the problem occurred and screen shot of the stuck step.

Or reply to the automated email sent by our call logging system with the requested log file and screen shot attached.

Are there any event viewer entries that would indicate a network or connection time out at the time the reported problem occurs?

Many Thanks
Eddie
_________________
Eddie Davis
Technical Support Engineer
Red Gate Software Ltd
E-mail: support@red-gate.com
Back to top
View user's profile Send private message Send e-mail
msurasky



Joined: 13 Mar 2014
Posts: 7
Location: Canada

PostPosted: Mon Apr 28, 2014 3:39 pm    Post subject: Reply with quote

Update:

I left the snapshot generation to run a few more hours and apparently after all these time it finally finished.

I'm not sure how many hours it took in the end or whether it really got stuck at some point in time or it was just SUPER slow.

Having said that, you replied asking me to provide the log. I have no problem in doing so but I have no idea where it is located.

If you point me to the Log file I will update the call with a copy of it. Unfortunately I can't attach also the screen shot because, as I said, the process completed after a few more hours.

Regards,
Back to top
View user's profile Send private message
fllouw



Joined: 26 May 2014
Posts: 2

PostPosted: Mon May 26, 2014 9:32 pm    Post subject: Reply with quote

I can confirm the same behavior. When registering the SQL database, SQL Compare 10.7 gets stuck at "Reading object text" on a large and complex database. Running sp_who2 against the database shows that the SPID is "SUSPENDED".

Checking the logs, I see:
Populate ObjectText start.
Remembered which version of System.Data.SQLite is in use: System.Data.SQLite, Version=1.0.85.0, Culture=neutral, PublicKeyToken=db937bc2d44ff139

Then, nothing.

Interesting: this database is about 250GB. A database with a similar schema but not data on the same server registers just fine.

Update: I ran a Trace and I see that SQL Compare is executing DBCC PAGE commands while the interface is unresponsive.

Thanks,
Francois
Back to top
View user's profile Send private message
fllouw



Joined: 26 May 2014
Posts: 2

PostPosted: Mon May 26, 2014 9:59 pm    Post subject: Reply with quote

An update: I found the reason for the performance difference. The large database had a single encrypted object (a 5-line stored procedure), and the option to decrypt encrypted objects was checked (it is checked by default). Unchecking the option to decrypt encrypted objects solved the performance issue.

Thanks,
Francois
Back to top
View user's profile Send private message
msurasky



Joined: 13 Mar 2014
Posts: 7
Location: Canada

PostPosted: Tue Jul 08, 2014 5:26 pm    Post subject: Re: Reply with quote

fllouw wrote:
An update: I found the reason for the performance difference. The large database had a single encrypted object (a 5-line stored procedure), and the option to decrypt encrypted objects was checked (it is checked by default). Unchecking the option to decrypt encrypted objects solved the performance issue.

Thanks,
Francois


Thanks fllouw, that also fix the performance problem in my case as well. Now the only question that remains is why option to decrypt encrypted objects causes so much overhead, but that is a question I will leave for another day.

Cheers!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group