Red Gate forums :: View topic - Folder is not a valid source?
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
Deployment Manager
Deployment Manager forum

Folder is not a valid source?

Search in Deployment Manager forum
Post new topic   Reply to topic
Jump to:  
Author Message
lee5i3



Joined: 16 Jul 2010
Posts: 38

PostPosted: Tue Oct 15, 2013 7:06 pm    Post subject: Folder is not a valid source? Reply with quote

I am using a SQL Database project, and I've been using the following command in TeamCity to package up the project


"%env.ProgramFiles%\Red Gate\Deployment Manager\Tools\RgPublish.exe" /source="%system.teamcity.build.workingDir%\trunk\source\My.Database" /target=feed:http://localhost:7070/nuget /packageid=My.Database /Configuration=Release

This has worked in the past, but haven't actually deployed in a while.. and now TeamCity is complaining..

[14:02:23][Step 3/6] Invalid source argument:
[14:02:23][Step 3/6] Could not interpret 'C:\TeamCity\buildAgent\work\92cb0b109899efe9\trunk\source\My.Database' as a valid source.
[14:02:23][Step 3/6] Process exited with code 1
[14:02:23][Step 3/6] Step Deploy My.Database (Command Line) failed
Back to top
View user's profile Send private message
james.billings



Joined: 16 Jun 2010
Posts: 1116
Location: My desk.

PostPosted: Tue Oct 15, 2013 7:42 pm    Post subject: Reply with quote

Hi Lee

Which version of RGPublish are you using? Can you try appending /verbose to the command to see if it logs more information?
Out of curiosity I tried packaging a folder with a period in the name using RGPublish and it was fine - although /Configuration isn't a switch I recognise, and my version certainly complained about it being there.
Back to top
View user's profile Send private message
lee5i3



Joined: 16 Jul 2010
Posts: 38

PostPosted: Tue Oct 15, 2013 9:49 pm    Post subject: Reply with quote

Red Gate Package Publishing Tool version 2.2.18.1

I'm not too sure why I put in Configuration, will remove it for now..

I added /verbose but didn't give anymore information
Back to top
View user's profile Send private message
lee5i3



Joined: 16 Jul 2010
Posts: 38

PostPosted: Tue Oct 15, 2013 9:53 pm    Post subject: Reply with quote

I also ran it manually on the server, I got the same error...
Back to top
View user's profile Send private message
lee5i3



Joined: 16 Jul 2010
Posts: 38

PostPosted: Tue Oct 15, 2013 9:55 pm    Post subject: Reply with quote

AHH, I figured it out... LOL

I renamed the project folder a while ago but didn't update my script, the "not a valid source", actually means the folder does not exist
Back to top
View user's profile Send private message
james.billings



Joined: 16 Jun 2010
Posts: 1116
Location: My desk.

PostPosted: Wed Oct 16, 2013 11:40 am    Post subject: Reply with quote

Ah, yes- that would be it Smile
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group