Red Gate forums :: View topic - Windows 2003 server issue with RedGateReleaseNumber
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
Deployment Manager
Deployment Manager forum

Windows 2003 server issue with RedGateReleaseNumber

Search in Deployment Manager forum
Post new topic   Reply to topic
Jump to:  
Author Message
rjayakumar



Joined: 21 Aug 2013
Posts: 8
Location: Bangalore

PostPosted: Wed Aug 21, 2013 8:00 am    Post subject: Windows 2003 server issue with RedGateReleaseNumber Reply with quote

I am trying to use physical path to deploy as
x:\AppName_$(RedGateReleaseNumber) and DM though created the physical folder - it failed to deploy any further files in to the newly created folder.

I am missing any other setting?

The other settings are as below

RedGateCreateWebSiteOnPort - 80
RedGateNotAWebSite - True
RedGatePurgePackageDirectoryBeforeCopy - True
RedGateWebSiteName - Default Web Site/AppName

The error message from the log is as below:

2013-08-21 06:32:17 INFO Purging the directory 'X:\AppPublish\AppName_1.8.3.1108'
2013-08-21 06:32:18 INFO Extracting package contents to 'X:\AppPublish\AppName_1.8.3.1108'
2013-08-21 06:32:18 ERROR Access to the path 'X:\AppPublish\AppName_1.8.3.1108\AccessDenied.aspx' is denied.
_________________
________
Cheers,
Raghunandan
Back to top
View user's profile Send private message Send e-mail
Mike Upton



Joined: 11 May 2011
Posts: 135
Location: Red Gate

PostPosted: Wed Aug 21, 2013 3:25 pm    Post subject: Reply with quote

Hi,

I've already replied to your support e-mail about this, but for the benefit of any others who might be reading this...

The access denied message means that the OS on your target machine is denying access to the specified folder, either due to permissions set on the target folder or because another process is locking the file. If you haven't customised any of the folder security settings, the most likely culprit is a virus scanner.
_________________
Mike Upton

Software Engineer
Red Gate Software Ltd.
Back to top
View user's profile Send private message
rjayakumar



Joined: 21 Aug 2013
Posts: 8
Location: Bangalore

PostPosted: Fri Aug 23, 2013 8:46 am    Post subject: Reply with quote

Mike,
the issue was more w.r.t the new physical path and the path associated to virtual directory mismatch. After having marked NotAWebsite = False - the new physical path has been set for virtual directory and the access denied is not appearing any more.

May be it is to do with the parameter value that the DM is looking to deploy the files.
_________________
________
Cheers,
Raghunandan
Back to top
View user's profile Send private message Send e-mail
rjayakumar



Joined: 21 Aug 2013
Posts: 8
Location: Bangalore

PostPosted: Fri Aug 23, 2013 8:49 am    Post subject: Reply with quote

Mike,
the issue was existing in 2003 still exists when the new path is used from the parameter. I am not sure of any security features affecting the deployment.

If we deploy without having to change the physical path - then there are no issues.

Would you mind for a quick screen share session?
_________________
________
Cheers,
Raghunandan
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group