Red Gate forums :: View topic - Persistent, Intermittent, WMI errors - SOLVED
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
SQL Monitor 3
SQL Monitor 3 forum

Persistent, Intermittent, WMI errors - SOLVED

Search in SQL Monitor 3 forum
Post new topic   Reply to topic
Jump to:  
Author Message
PDinCA



Joined: 25 Jul 2005
Posts: 511
Location: Costa Mesa, CA, USA

PostPosted: Sat Feb 02, 2013 2:38 am    Post subject: Persistent, Intermittent, WMI errors - SOLVED Reply with quote

Monitor (3.2.0.219), Running as: NT AUTHORITY\SYSTEM (Service)
Also, using a sysadmin DB server role for the cluster name, and 2 nodes login, with SQL sa as the "local" credentials.

Usually at least 3 or 4 times a week, sometimes twice a day, at unpredictable times, SQL Monitor will send an Alert:
Code:
ID:   2490436
SQL Server:   (local)
Machine:   <<The Cluster>>
Alert type:   Monitoring error (SQL Server data collection)
Level:   None
Time raised:   1 Feb 2013 8:01 PM (UTC-05)
Time ended:   1 Feb 2013 8:04 PM (UTC-05)


I need to send you a file of the base monitor log as this has been going on for many months without resolution.

The hosting company's Windows experts have changed what I believe is the packet authentication to public as we had seen a number of security messages and rebooted each node.

I ran the WMI Test and have 160 Win32_Service objects.

As I said, the issue is INTERMITTENT. I caught the log file this time. I'd like to upload it so your experts can see what's up as I'd like to have a reliable monitor, please...


Last edited by PDinCA on Fri Mar 22, 2013 9:39 pm; edited 1 time in total
Back to top
View user's profile Send private message
chriskelly



Joined: 19 Apr 2010
Posts: 329
Location: Cambridge, UK

PostPosted: Mon Feb 04, 2013 6:12 pm    Post subject: Reply with quote

Please can you gather the SQL Monitor error logs (as per the link below and ensuring that they cover the period of the error) and confirm the following details:

- version of Windows and SQL Server for the machine you are trying to monitor (full version numbers please).
- did you run the WMI test on the Base Monitor host machine and connect to the machine you are trying to monitor?

http://www.red-gate.com/supportcenter/content/SQL_Monitor/help/3.0/SM_LogFiles

Please send to support@red-gate.com and include the support ticket number F0069194 in the subject line.

We can then try to investigate.
_________________
Chris Kelly
Technical Support Engineer
Back to top
View user's profile Send private message
PDinCA



Joined: 25 Jul 2005
Posts: 511
Location: Costa Mesa, CA, USA

PostPosted: Mon Feb 04, 2013 6:49 pm    Post subject: Reply with quote

Email sent, thanks, Chris.
Back to top
View user's profile Send private message
PDinCA



Joined: 25 Jul 2005
Posts: 511
Location: Costa Mesa, CA, USA

PostPosted: Mon Mar 18, 2013 5:43 pm    Post subject: Reply with quote

A Rackspace technician suggested the following, which has completely cleared the issue: "To rule DNS out as a cause of the problem, I would like to edit the host file on this server with the short and FQDN entries for the cluster nodes and devices to see if this either solves the problem or excludes DNS from our troubleshooting."

Case closed!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group