Red Gate forums :: View topic - SQL Source Control 3.1 Failed to load or caused an exception
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
SQL Source Control 3
SQL Source Control 3 forum

SQL Source Control 3.1 Failed to load or caused an exception

Search in SQL Source Control 3 forum
Post new topic   Reply to topic
Jump to:  
Go to page 1, 2  Next
Author Message
sproatba



Joined: 27 Jan 2012
Posts: 10

PostPosted: Wed Jan 23, 2013 10:31 pm    Post subject: SQL Source Control 3.1 Failed to load or caused an exception Reply with quote

I get this every time i launch ssms. It affects all versions of ssms. It started after the upgrade to 3.1.0.5208. I've tried to reinstall. Reverting to the previous version works.
Back to top
View user's profile Send private message
MBBW



Joined: 08 Mar 2011
Posts: 12

PostPosted: Thu Jan 24, 2013 7:16 pm    Post subject: Reply with quote

SSC 3.1.0.5208
SQL Server 10.50.4000

I have the same issue! After upgrading to 3.1.0.5208 I cannot work anymore. The following error occurs (translated):
Code:
The assembly "RedGate.SQLSourceControl.AtomicIO, Version=3.1.0.4829, Culture=neutral, PublicKeyToken=7f465a1c156d4d57" cannot be found.

Also uninstalling SSC, rebooting and installing 3.1.0.5208 did not succeed!

Please provide a link to download the version 3.1.0.4829!
Back to top
View user's profile Send private message
ScottA



Joined: 13 Apr 2012
Posts: 8
Location: Australia

PostPosted: Mon Feb 04, 2013 11:14 am    Post subject: Reply with quote

I've just had this problem also. Error comes up in SQL 208 R2 and 2012 management studio when loading.

The event log has a lot of the following from the source "SQL Source Control 3" and "SQL Test 1"

#QEc.#mRA
#1:Failed to load assembly RedGate.SQLPrompt.SSMSUIfw4.resources.resources, Version=5.3.6.28, Culture=en-US, PublicKeyToken=7f465a1c156d4d57

Broke my golden rule of doing an upgrade when I actually needed to do a UAT update and needed to generate some scripts, it's a testament to Redgate though as I'm so used to their upgrades working flawlessly that i didn't give it a second thought!
Back to top
View user's profile Send private message
andy.campbell.smith



Joined: 20 Oct 2011
Posts: 159
Location: Red Gate Software

PostPosted: Mon Feb 04, 2013 8:38 pm    Post subject: Reply with quote

You can download SQL Source Control 3.1.0.4829 here:
ftp://support.red-gate.com/patches/SQLSourceControl/23Oct2012/SQLSourceControl_3.1.0.4829.exe

That event log error isn't really important - SQL Prompt and SQL Test log a lot of errors like that, but they're quite resilient, so if those products don't actually throw an error to the user then it's nothing to worry about. We're looking into the SQL Source Control error now - I'll let you know as soon as I have an update for you.
_________________
Andy Campbell Smith

Red Gate Technical Support Engineer
Back to top
View user's profile Send private message
vic.kirkpatrick



Joined: 05 Feb 2013
Posts: 3
Location: Atlanta, GA

PostPosted: Tue Feb 05, 2013 3:45 pm    Post subject: Reply with quote

Got the prompt to upgrade SQL Source Control and did it. Now, none of my databases are linked to source control, and if I try to link them, I get:
Unable to find assembly 'RedGate.SQLSourceControl.AtomicIO, Version=3.1.2.33, Culture=neutral, PublicKeyToken=7f465a1c156d4d57'.
A rollback to a previous version of SQL Source Control still gives the same error.
Back to top
View user's profile Send private message
ScottA



Joined: 13 Apr 2012
Posts: 8
Location: Australia

PostPosted: Wed Feb 06, 2013 12:00 am    Post subject: Reply with quote

Hi Vic,

I downgraded to 3.0 which brought it all back for me.
Back to top
View user's profile Send private message
andy.campbell.smith



Joined: 20 Oct 2011
Posts: 159
Location: Red Gate Software

PostPosted: Wed Feb 06, 2013 12:31 pm    Post subject: Reply with quote

Any salient information any of you can provide would be really helpful - unfortunately, this is a fairly generic Windows error, which means SQL Source Control is crashing before it loads far enough to give a useful error message or stack trace.

We're doing our best to track this error down, and we've logged it in our internal bug-tracking system as SOC-4649. Since it's not affecting everyone and we can't reproduce it, we're not getting very far, so any information you can provide at all would be helpful - your OS, version of SSMS, any details about how you were using SQL Source Control, or anything else you think might be relevant. Thanks for your help!
_________________
Andy Campbell Smith

Red Gate Technical Support Engineer
Back to top
View user's profile Send private message
vic.kirkpatrick



Joined: 05 Feb 2013
Posts: 3
Location: Atlanta, GA

PostPosted: Wed Feb 06, 2013 1:14 pm    Post subject: Reply with quote

Thanks Scott, I will try to downgrade to 3.0 in a minute if I can find it somewhere. The redgate previous versions download page only has a 2.2 as the latest for Source Control.

Andy, ok, here is some info:
Win7 Enterprise, SP1
SSMS ver 10.0.5512.0
We use SSC with mercurial in a shared database env. I pick my source control folder and click the link button... it always gets to 10% then gets this error.
Back to top
View user's profile Send private message
andy.campbell.smith



Joined: 20 Oct 2011
Posts: 159
Location: Red Gate Software

PostPosted: Wed Feb 06, 2013 1:37 pm    Post subject: Reply with quote

Ah, right - Vic, I think you're seeing a different error to the one in the original post of this thread, which is where SQL Source Control crashes instantly upon loading SSMS. Your error is SOC-3914, which is a considerably rarer error, but we should actually be able to make some progress with your one, since we get a stack trace when it throws the error.

It looks like that error is because we're trying to load the wrong version of one of the SQL Source Control components - I'd guess this is from a failed install, but if you tried rolling back to a previous version that ought to have fixed it. Can I get you to completely uninstall SQL Source Control and try installing the latest version again, making sure to right-click the installer and run as Administrator? The installer for the newest version is here:

ftp://support.red-gate.com/patches/SQLSourceControl/05Feb2013/SQLSourceControl_3.1.3.26.exe

If that doesn't fix it we'll need to start digging around to figure out what went wrong in that install. Your case is particularly interesting, because it looks like you're trying to load a newer version of the component than the version of SQL Source Control you've got installed, which shouldn't ever happen.

I'm logging you a support ticket now so we don't clutter up this thread - you should get a confirmation email very soon. If we could continue troubleshooting this by email that'd be great, just so we don't get confused with two separate issues in this thread.
_________________
Andy Campbell Smith

Red Gate Technical Support Engineer
Back to top
View user's profile Send private message
vic.kirkpatrick



Joined: 05 Feb 2013
Posts: 3
Location: Atlanta, GA

PostPosted: Wed Feb 06, 2013 3:27 pm    Post subject: Reply with quote

Thanks Andy. I've tried the 3.1.3.26.exe and the install completes successfully, but the problem still persists. Further replies on this issue via email.

Scott, FYI, a downgrade to 3.0 did not help me, but 2.2 did help. However, any attempts to upgrade to any 3.x version do not help me link dbs to source control.
Back to top
View user's profile Send private message
sproatba



Joined: 27 Jan 2012
Posts: 10

PostPosted: Thu Feb 21, 2013 2:29 pm    Post subject: Reply with quote

Any progress on this?
Back to top
View user's profile Send private message
pahlquist



Joined: 28 Feb 2013
Posts: 2

PostPosted: Thu Feb 28, 2013 6:38 pm    Post subject: Reply with quote

I've got the same issue. In SQL 2008 R2 SSMS I was prompted to upgrade from 3.0.13.4214 to 3.1.4.72. After doing this (install ran successfully), every time I open SSMS I get the error "The Add-in 'SQL Source Control 3.1' failed to load or caused an exception......Error Message: <Unknown Error> Error number: 80131500". Uninstalling and then reinstalling 3.0.13.4214 gets me back in business. Let me know if there is additional information I can send you...
Back to top
View user's profile Send private message
sproatba



Joined: 27 Jan 2012
Posts: 10

PostPosted: Thu Mar 14, 2013 4:48 pm    Post subject: Reply with quote

We've found that others in my department encounter the same issue when upgrading. Could it have to do with us not having a subscription to some of the latest versions?
Back to top
View user's profile Send private message
ScottA



Joined: 13 Apr 2012
Posts: 8
Location: Australia

PostPosted: Tue Mar 19, 2013 12:50 pm    Post subject: Reply with quote

I just upgraded to 3.2 thinking this might have been sorted but the issue still remains in this build.

I'll need to reinstall 3.0 again to now as I need this working but am happy to send through any debug info / run any tests to get this sorted ASAP.

I am also using SQL 2008 R2, 64bit windows 8.

Cheers,
Back to top
View user's profile Send private message
sproatba



Joined: 27 Jan 2012
Posts: 10

PostPosted: Tue Mar 19, 2013 12:58 pm    Post subject: Reply with quote

Doing some digging on my own, I found that there was an issue in the past with redgate tools and another ssms application called SSMS Tools which I also use. So far uninstalling SSMS Tools didn't help, but perhaps its leftover from other tools we tried before deciding on redgate. I'm wondering if anyone else who is having this issue has other plugins enabled in SSMS?

As Scott mentioned, i'd be willing to capture crash dumps or run tests to help track this down I just need to know what to do.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Go to page 1, 2  Next
Page 1 of 2

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group