Red Gate forums :: View topic - Could not start IIS.
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
ANTS Performance Profiler 7
ANTS Performance Profiler 7 forum

Could not start IIS.

Search in ANTS Performance Profiler 7 forum
Post new topic   Reply to topic
Jump to:  
Author Message
hetalm



Joined: 18 Jan 2013
Posts: 1

PostPosted: Fri Jan 18, 2013 7:57 am    Post subject: Could not start IIS. Reply with quote

I am using Windows Server 2008 R2, IIS 7.0

When i try to profile an application hosted on IIS it gives me following error

Note : I have my App-Pool Identity set to Network Services and have updated the ANTS Performance Profiler 7 Service to the same.


Could not start IIS.
RedGate.Profiler.Engine.Exceptions.CannotStartSessionException
at ..Launch()
at ?..?()

Caused by:

Could not start IIS.
RedGate.Profiler.Engine.Exceptions.CannotStartIisSessionException
at ..()
at ..Launch()

Caused by:

Couldn't locate applicationHost.config - ensure IIS is installed, and you are running as an Administrator
RedGate.Profiler.Engine.Exceptions.CannotStartIisSessionException
at ?.?.??()
at ..??( )
at ..()

Caused by:

Couldn't locate applicationHost.config - ensure IIS is installed, and you are running as an Administrator
RedGate.Profiler.Engine.Startup.IIS.IISException
stack trace:
at RedGate.Profiler.Engine.Startup.IIS.IIS7Utilities.??()
at RedGate.Profiler.Engine.Startup.IIS.IIS7Utilities.??(String , Uri , Boolean , Int32 )
at RedGate.Profiler.Engine.Startup.IIS.IIS7Utilities.(Uri , Boolean , Int32 )
at ..(Uri , IISUtilities )
at ..StartProfilingIIS(String , String )
at RedGate.Profiler.Engine.Startup.IIS.IISStarter`1.StartProfilingIIS(String currentUserName, String subprocessVariableValue)
at System.Runtime.Remoting.Messaging.StackBuilderSink._PrivateProcessMessage(IntPtr md, Object[] args, Object server, Int32 methodPtr, Boolean fExecuteInContext, Object[]& outArgs)
at System.Runtime.Remoting.Messaging.StackBuilderSink.SyncProcessMessage(IMessage msg, Int32 methodPtr, Boolean fExecuteInContext)
rethrown at [0]:
at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
at RedGate.Profiler.Engine.Startup.IIISActuator`1.StartProfilingIIS(String currentUserName, String subprocessVariableValue)
at ?.?.??()
Back to top
View user's profile Send private message
Chris.Allen



Joined: 12 Mar 2009
Posts: 594

PostPosted: Mon Jan 21, 2013 1:24 pm    Post subject: Reply with quote

Sorry you had an issue with ANTS- IIS starting is often troublesome because of complicated permission regimes. (You're obviously aware of this having had to change the service rights too).

You'll get most chance of joy by running ANTS elevated (as administrator).

Try right-clicking on the ANTS UI executable.

If it doesn't work first time, please revert he ANTS service as LOCAL SYSTEM too.

If that doesn't work- are you averse to installing Microsoft's Webmatrix (as this *just works* anytime, any place)?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group