Red Gate forums :: View topic - Enable Manual Check for Changes to Large Database
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
SQL Source Control 3
SQL Source Control 3 forum

Enable Manual Check for Changes to Large Database

Search in SQL Source Control 3 forum
Post new topic   Reply to topic
Jump to:  
Author Message
jkennedy



Joined: 26 Jul 2012
Posts: 9

PostPosted: Thu Jul 26, 2012 4:32 pm    Post subject: Enable Manual Check for Changes to Large Database Reply with quote

We have 2 of our 20 or so databases that are very large (30k objects). Right now, every time that I access those databases, a check for changes is triggered. This can take 20 minutes to an hour to complete. That entire time these activities are competing with more important processes. Is there a way to trigger a manual check once a week or so for these dbs? We're using TFS as a repository.
Back to top
View user's profile Send private message
eddie davis



Joined: 14 Jun 2006
Posts: 889
Location: Red Gate Software

PostPosted: Mon Jul 30, 2012 11:22 am    Post subject: Reply with quote

Thank you for your post into the forum.

I hope the following work around maybe useful to you:

If your server is struggling due to the default blue indicator polling frequency, it is possible to reconfigure it.

All SQL Source Control users need to set this individually.

To achieve this you will need to close SSMS, and edit the 'RedGate_SQLSourceControl_Engine_EngineOptions' in your SQL Source Control configuration directory. This is either: C:\Users\<username>\AppData\Local\Red Gate\SQL Source Control 3 or C:\Documents and Settings\<username>\Local Settings\Application Data\Red Gate\SQL Source Control 3 depending on your operating system version.

Add the following node (as a child of the EngineOptions node) to the file:

<PollingEnabled>False</PollingEnabled>

The regular polling on your server to determine what you've changed won't happen. This means that to see the blue indicators in the Object Explorer you will need to visit the Commit tab.

Many Thanks
Eddie
_________________
Eddie Davis
Technical Support Engineer
Red Gate Software Ltd
E-mail: support@red-gate.com
Back to top
View user's profile Send private message Send e-mail
jkennedy



Joined: 26 Jul 2012
Posts: 9

PostPosted: Mon Jul 30, 2012 7:15 pm    Post subject: Reply with quote

Thanks for the quick reply Eddie. I'm still unable to disable the auto check for updates. I updated RedGate_SQLSourceControl_Engine_EngineOptions.xml in
C:\Users\[my username]\AppData\Local\Red Gate\SQL Source Control 3\RedGate_SQLSourceControl_Engine_EngineOptions.xml to reflect the following:

<?xml version="1.0" encoding="utf-16" standalone="yes" ?>
- <!-- SQL Compare 10
SQL Compare
Version:10.1.0.102
-->
- <EngineOptions version="2" type="EngineOptions">
<PollingEnabled>False</PollingEnabled>
</EngineOptions>

Then completely restarted.

I also tried:

<?xml version="1.0" encoding="utf-16" standalone="yes" ?>
- <!-- SQL Compare 10
SQL Compare
Version:10.1.0.102
-->
- <EngineOptions version="2" type="EngineOptions">
<Polling-Enabled>False</Polling-Enabled>
</EngineOptions>

I'm still getting the auto-check for modifications. Is there anything else that I can try?
Back to top
View user's profile Send private message
eddie davis



Joined: 14 Jun 2006
Posts: 889
Location: Red Gate Software

PostPosted: Thu Aug 02, 2012 1:34 pm    Post subject: Reply with quote

Thank you for your reply.

Not sure where or why you are picking up or including the SQL Compare infomation version information.

The RedGate_SQLSourceControl_Engine_EngineOptions.xml before editing should be as follows:

Code:


<?xml version="1.0" encoding="UTF-16" standalone="true"?>

<!---->
<EngineOptions type="EngineOptions" version="2"/>


After editing should look be as follows:


Code:

<?xml version="1.0" encoding="UTF-16" standalone="true"?>

<!---->
<EngineOptions type="EngineOptions" version="2">
       <PollingEnabled>False</PollingEnabled>
</EngineOptions>


Many Thanks
Eddie
_________________
Eddie Davis
Technical Support Engineer
Red Gate Software Ltd
E-mail: support@red-gate.com
Back to top
View user's profile Send private message Send e-mail
jkennedy



Joined: 26 Jul 2012
Posts: 9

PostPosted: Wed Aug 08, 2012 2:59 pm    Post subject: Reply with quote

Hello Eddie, thanks again for reaching out. Sorry for the confusion above. I was attempting a number of different options to try to get this to work. I applied to code below to C:\Documents and Settings\[my username]\Local Settings\Application Data\Red Gate\SQL Source Control 3\RedGate_SQLSourceControl_Engine_EngineOptions.xml and I still can't seem to disable polling. I'm not sure if it matters, but I do have SQL Server 2008r2, and SQL Server 2012 installed on my local. After making the change below, I attempted to access Source Control in each enviornment through SSMS and it is still "Checking for Changes" on initial click of each db.

Code:
<?xml version="1.0" encoding="UTF-16" standalone="true"?>

<!---->
<EngineOptions type="EngineOptions" version="2">
       <PollingEnabled>False</PollingEnabled>
</EngineOptions> 



I even tried deleting and reinstalling SQL Source Control and it didn't help. Any other thoughts?
Back to top
View user's profile Send private message
eddie davis



Joined: 14 Jun 2006
Posts: 889
Location: Red Gate Software

PostPosted: Wed Aug 08, 2012 3:41 pm    Post subject: Reply with quote

Thank you for your reply.

Can you please try a slight alteration to the xml code and change the version number to 3, so it becomes:
Code:

<?xml version="1.0" encoding="UTF-16" standalone="true"?>

<!---->
<EngineOptions type="EngineOptions" version="3">
       <PollingEnabled>False</PollingEnabled>
</EngineOptions> 


One of my colleagues handled a similar call and the above change was made which resolved the issue and stopped the constant polling by SQL Source Control.

Many Thanks
Eddie
_________________
Eddie Davis
Technical Support Engineer
Red Gate Software Ltd
E-mail: support@red-gate.com
Back to top
View user's profile Send private message Send e-mail
jkennedy



Joined: 26 Jul 2012
Posts: 9

PostPosted: Thu Aug 09, 2012 2:30 pm    Post subject: Reply with quote

Greetings Eddie, thanks for helping me dig through. I implemented the code change you suggested below, and polling continues. I also tried the below version using standalone="yes" instead of standalone="true", as per some other XML posts that I came across. Do you have any other thoughts. Are any of these setting dependant on OS version, SQL version, or some other attribute? I'd also be happy to give you a call if that would make it easier.

Code:

 <?xml version="1.0" encoding="UTF-16" standalone="yes" ?>
- <!--
  -->
- <EngineOptions type="EngineOptions" version="3">
  <PollingEnabled>False</PollingEnabled>
  </EngineOptions>
Back to top
View user's profile Send private message
jkennedy



Joined: 26 Jul 2012
Posts: 9

PostPosted: Fri Aug 10, 2012 4:42 pm    Post subject: Reply with quote

Just offering an update: I uninstalled RegGate Source Control again and completely deleted the C:\Users\[me]\AppData\Local\Red Gate\SQL Source Control 3 directory. I then reinstalled based on the most recent developer bundle from the redgate site and updated RedGate_SQLSourceControl_Engine_EngineOptions.xml to look like this.

Code:
<?xml version="1.0" encoding="UTF-16" standalone="yes"?>

<!---->
<EngineOptions type="EngineOptions" version="3">
       <PollingEnabled>False</PollingEnabled>
</EngineOptions> 


After I restarted SSMS and relinked a database, I'm still polling. Any other thoughts?
Back to top
View user's profile Send private message
eddie davis



Joined: 14 Jun 2006
Posts: 889
Location: Red Gate Software

PostPosted: Tue Aug 14, 2012 10:05 am    Post subject: Reply with quote

Thank you for your reply.

I have been discussing your problem with my colleagues in the Support Team. My colleagues do not think that your issue is the polling problem. They suspect that your issue is this User Voice Forum TOPIC.

The topic is a request for the 'Commit Changes / Get Latest' to be a manual process and not be an automatic process. Can you please click on the link and read through this User Voice topic and if the topic matches your problem, can you please add a comment and vote for it?

Many Thanks
Eddie
_________________
Eddie Davis
Technical Support Engineer
Red Gate Software Ltd
E-mail: support@red-gate.com
Back to top
View user's profile Send private message Send e-mail
jkennedy



Joined: 26 Jul 2012
Posts: 9

PostPosted: Tue Aug 14, 2012 2:27 pm    Post subject: Reply with quote

Thanks Eddie. That pretty much sums it up. I really hope that this gets some looks from the dev team. And thanks again for all the time you put into answering my question.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group