Red Gate forums :: View topic - SQL Monitor issues with Windows Registry
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
SQL Monitor 4
SQL Monitor 4 forum

SQL Monitor issues with Windows Registry

Search in SQL Monitor 4 forum
Post new topic   Reply to topic
Jump to:  
Author Message
TheLonelyDBA



Joined: 30 Oct 2013
Posts: 18
Location: Brazil

PostPosted: Mon May 05, 2014 7:35 pm    Post subject: SQL Monitor issues with Windows Registry Reply with quote

Hi. I just opened this topic to register one issue I found while testing SQL Monitor Hosted - and the solution found.

I was having some errors while trying to set up the monitoring on my Windows Server 2008R2 box, all related to the registry key "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Time Zones"

It turns out the server did NOT have a valid TimeZone configured. It is easy to check this by cliking on the clock on the taskbar. Once the correct timezone was selected, this error stopped happening, resuming monitoring activities.

Unfortunately I do not have the specific error messages anymore, but I believe this happened on servers that where virtualized from physical - a process I know as "P2V". As I already fixed my server I could not reproduce this error anymore.

I hope this helps someone in the future, either with Hosted or On-Premise SQLMonitor versions.
_________________
Tips and thoughts on MS SQL, Oracle and MongoDB:
http://thelonelydba.wordpress.com
Back to top
View user's profile Send private message
Evan Moss



Joined: 12 Jun 2013
Posts: 99

PostPosted: Wed May 07, 2014 7:49 pm    Post subject: Reply with quote

Hello,

Thanks for your post and feedback.

You're correct that you need a valid time zone set. SQL Monitor uses the value of HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\TimeZoneInformation\TimeZoneKeyName to look up more information about your timezone, and that will fail if your TimeZoneInformation key has an invalid value.

For anyone else interested, this is what the error will look like:



Thanks again,
Evan
_________________
Evan Moss
Product Support
(866) 627-8107
Back to top
View user's profile Send private message Send e-mail
TheLonelyDBA



Joined: 30 Oct 2013
Posts: 18
Location: Brazil

PostPosted: Wed May 07, 2014 8:18 pm    Post subject: Reply with quote

thanks for your detailed explanation, Evan.

I tried to do a search about the error before posting here, but could not find an index of messages/codes. do you guys have anything like that to help us?

regards,
_________________
Tips and thoughts on MS SQL, Oracle and MongoDB:
http://thelonelydba.wordpress.com
Back to top
View user's profile Send private message
Evan Moss



Joined: 12 Jun 2013
Posts: 99

PostPosted: Thu May 08, 2014 5:35 pm    Post subject: Reply with quote

Unfortunately there isn't a good list of error codes. (You're referring to the #fsG in the screenshot above, right?)

Thanks,
Evan
_________________
Evan Moss
Product Support
(866) 627-8107
Back to top
View user's profile Send private message Send e-mail
TheLonelyDBA



Joined: 30 Oct 2013
Posts: 18
Location: Brazil

PostPosted: Thu May 08, 2014 10:40 pm    Post subject: Reply with quote

yes, I was referring to the "#fsG" (and any other code too).
_________________
Tips and thoughts on MS SQL, Oracle and MongoDB:
http://thelonelydba.wordpress.com
Back to top
View user's profile Send private message
TheLonelyDBA



Joined: 30 Oct 2013
Posts: 18
Location: Brazil

PostPosted: Mon May 12, 2014 10:01 pm    Post subject: Reply with quote

Evan, could you help me out on another registry entry?

Error: Status: Monitoring stopped (Incorrect credentials or insufficient permissions)
Date: 12 May 2014 5:45 PM
Group: Registry
Event: OpenSubKeyOrNone: \\<my_machine_02>\HKEY_LOCAL_MACHINE\Cluster
Outcome: Incorrect credentials or insufficient permissions
Exception: Win32Exception
Exception message: Access is denied

the problem is: the account used is local administrator, and such "Cluster" key/value does not exist in the registry hive listed. This is a standalone w2008 server that should not have anything labeled "cluster" on it.

ty
_________________
Tips and thoughts on MS SQL, Oracle and MongoDB:
http://thelonelydba.wordpress.com
Back to top
View user's profile Send private message
TheLonelyDBA



Joined: 30 Oct 2013
Posts: 18
Location: Brazil

PostPosted: Mon May 12, 2014 10:09 pm    Post subject: Reply with quote

aaaaand same message is happening to another server, again without any cluster services on it. Shocked
_________________
Tips and thoughts on MS SQL, Oracle and MongoDB:
http://thelonelydba.wordpress.com
Back to top
View user's profile Send private message
GFritchey



Joined: 29 Nov 2010
Posts: 7
Location: Massachusetts

PostPosted: Tue May 13, 2014 7:55 pm    Post subject: Sorry Reply with quote

I know you asked me to come by and help out here, but I don't have access to the code to understand what's going wrong. Sorry about that. I'm positive Evan will take care of you.
Back to top
View user's profile Send private message
Evan Moss



Joined: 12 Jun 2013
Posts: 99

PostPosted: Tue May 13, 2014 8:19 pm    Post subject: Reply with quote

Hello,

Sorry I missed these posts; I must've had my notification settings wrong.

Can you try running the remote registry test on this page? http://documentation.red-gate.com/pages/viewpage.action?pageId=20743047

You'll have to run the test from the machine running the base monitor service using the same credentials to connect that the base monitor is using.

This should expose where the problem is occurring.

If that doesn't help, can we continue troubleshooting through our ticketing system? We have a ticket open for you (reference 19121)

Thanks,
Evan
_________________
Evan Moss
Product Support
(866) 627-8107
Back to top
View user's profile Send private message Send e-mail
TheLonelyDBA



Joined: 30 Oct 2013
Posts: 18
Location: Brazil

PostPosted: Tue May 13, 2014 10:55 pm    Post subject: Reply with quote

hi Evan! I'm so glad you are back Smile

of course I will run the test you pointed me. and I will update the support request inside the ticketing system (I guess I should have asked for help there, but could not think straight with this registry thing on my head).

again, sorry for rushing you guys so much - but as the beta will go off at the end of this month, I wanted it up and running to showcase to a few co-workers here before that date.

thanks!
_________________
Tips and thoughts on MS SQL, Oracle and MongoDB:
http://thelonelydba.wordpress.com
Back to top
View user's profile Send private message
TheLonelyDBA



Joined: 30 Oct 2013
Posts: 18
Location: Brazil

PostPosted: Fri May 16, 2014 11:09 pm    Post subject: Reply with quote

Hello Evan!

Sorry I rushed you so much, and took this long to post back! for the past 2 days I was busy running your tests and configuring the SQL Monitor Hosted collection. As I believe you can see from my account, IT WORKED! =D

You were correct: we had some permission issues on our side. Our network is higly "firewalled" and we also have 2 distinct domains, without any direct trust relationship.

Because of this issue, I was trying to configure the Relay server using local server accounts, as the monitoring server will not always be able to authenticate on the monitored instance domain. Unfortunately this did not work well - the connection was made, but some pieces of it didn't work. The tests you suggested were key to confirm it.

I had to resort to using my own domain account to do the data collection, and give up on monitoring the servers at the second domain. But for now it is working as expected.

I would just like to ask one question before we close this support request:
- do you know if in the future it would be possible to use Local accounts instead of Domain accounts to do the collection?

thanks,
_________________
Tips and thoughts on MS SQL, Oracle and MongoDB:
http://thelonelydba.wordpress.com
Back to top
View user's profile Send private message
TheLonelyDBA



Joined: 30 Oct 2013
Posts: 18
Location: Brazil

PostPosted: Fri May 30, 2014 10:08 pm    Post subject: Reply with quote

Hi Evan. we tried to open the firewall ports but could not get the WMI ports on target servers fixed, so we could not monitor them after all. Also because of secondary domain here, another thing I tried to overcome this was installing a second relay on a different server, but the installation would give me a error about the relay already existing.

Unfortunately our corporate network policies prevent us from using it to monitor all our databases in one single monitoring instance.

if possible, I would like to give the suggestion to allow more than 1 relay to be installed. for corporate networks with such restricted rules it would be great to have a relay for each VLAN/Domain.
_________________
Tips and thoughts on MS SQL, Oracle and MongoDB:
http://thelonelydba.wordpress.com
Back to top
View user's profile Send private message
Evan Moss



Joined: 12 Jun 2013
Posts: 99

PostPosted: Mon Jun 02, 2014 5:10 pm    Post subject: Reply with quote

Hello,

We have an existing feature request on our uservoice forum here: http://sqlmonitor.uservoice.com/forums/91743-suggestions/suggestions/1890769-create-a-central-web-interface-that-can-access-mul

It'd be great if you could vote on that.

Thanks,
Evan
_________________
Evan Moss
Product Support
(866) 627-8107
Back to top
View user's profile Send private message Send e-mail
TheLonelyDBA



Joined: 30 Oct 2013
Posts: 18
Location: Brazil

PostPosted: Mon Jun 02, 2014 8:10 pm    Post subject: Reply with quote

thanks for pointing that, Evan! I voted for it, because it is my main request regarding this product.

thanks for all!
_________________
Tips and thoughts on MS SQL, Oracle and MongoDB:
http://thelonelydba.wordpress.com
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group