Red Gate forums :: View topic - Error when creating new release
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
Deployment Manager
Deployment Manager forum

Error when creating new release

Search in Deployment Manager forum
Post new topic   Reply to topic
Jump to:  
Go to page Previous  1, 2
Author Message
Mike Upton



Joined: 11 May 2011
Posts: 157
Location: Red Gate

PostPosted: Thu Jul 25, 2013 8:57 am    Post subject: Reply with quote

It appears that this message occurs when the Deployment Agent is unreachable for any reason. What status is the target machine showing in the Environments overview? If the machine is offline, then either the Deployment Agent service is not running, or the machine and/or service port is not reachable from the Deployment Manager server.

To check whether the Deployment Agent is running, check the state of the 'Red Gate Deployment Agent' service on the target machine.

To check connectivity with the agent, you can try pinging the agent from the machine that the Deployment Manager server is installed on. If that works, you can also try navigating to http://<your-agent-machine-address>:10301/ in a browser on the Deployment Manager server machine; you should see an HTML page that starts with the message:

Quote:
Service

This is a Windows© Communication Foundation service.

Metadata publishing for this service is currently disabled...

If the service is running but you can't reach the service page from a browser, the most likely reason is that a firewall is getting in the way. Port 10301 needs to be opened on the agent machine to allow the server to communicate with it.

As an aside, the misleading message about timeouts happens because we use WCF reliable sessions with message level security, and they retry operations until a timeout rather than providing useful error messages.
_________________
Mike Upton

Software Engineer
Red Gate Software Ltd.
Back to top
View user's profile Send private message
spike



Joined: 17 Jul 2013
Posts: 9

PostPosted: Thu Jul 25, 2013 4:29 pm    Post subject: Reply with quote

Got it working thanks. I am trying to connect to an agent that is on a different network, the firewall is turned off on the agent machine so port 10301 should not be be blocked.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Go to page Previous  1, 2
Page 2 of 2

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group