Red Gate forums :: View topic - Changeset Comments Policy Error
Return to www.red-gate.com RSS Feed Available

Search  | Usergroups |  Profile |  Messages |  Log in  Register 
Go to product documentation
SQL Source Control 3
SQL Source Control 3 forum

Changeset Comments Policy Error

Search in SQL Source Control 3 forum
Post new topic   Reply to topic
Jump to:  
Author Message
flyer299



Joined: 12 Apr 2010
Posts: 6

PostPosted: Fri May 24, 2013 3:26 pm    Post subject: Changeset Comments Policy Error Reply with quote

I have Team Foundation server setup to require a Check In Comment on all check ins. I was excited to see that SQL Source was going to support this feature.

When we upgraded to the new version, even if we enter a comment we get an error.

"This Commit doesn't meet the server's policy requirements, or the policy isn't configured on your machince. The Server returned the follwing "Internal error in ChangeShet commetns Policy. Error loading the changeset comments Policy policy."

It does reference a CheckForComments.CS with instructions. Please help? We are dead in the water and can't check code in right now!
Back to top
View user's profile Send private message
eugef



Joined: 29 May 2013
Posts: 15

PostPosted: Wed May 29, 2013 10:22 pm    Post subject: Reply with quote

Same exact problem.

SQL Source stopped working after latest update.


P.S. I evaluated the tool and pushed my manager hard to purchase a licence for it which he finally agreed to do, however 2 days after activation i have upgraded the the version and it stopped working. Please, fix it ASAP!!!!
Back to top
View user's profile Send private message
eugef



Joined: 29 May 2013
Posts: 15

PostPosted: Wed May 29, 2013 10:27 pm    Post subject: Reply with quote

Oh and one more thing:

I followed the instructions to disable TfsPolicies here http://documentation.red-gate.com/display/SOC34/Turning+off+TFS+policy+checking and it didn't resolve the problem
Back to top
View user's profile Send private message
eugef



Joined: 29 May 2013
Posts: 15

PostPosted: Fri May 31, 2013 10:02 pm    Post subject: Reply with quote

I would appreciate any response from Red-Gate support team
Back to top
View user's profile Send private message
james.billings



Joined: 16 Jun 2010
Posts: 1112
Location: My desk.

PostPosted: Mon Jun 03, 2013 12:27 pm    Post subject: Reply with quote

Hi,
Sorry to hear you're having some trouble. Disabling should work fine- but only on the very latest release. What version are you on?

If you are on the latest, can you post the config file change you made so we can double check it looks correct?
Back to top
View user's profile Send private message
eugef



Joined: 29 May 2013
Posts: 15

PostPosted: Mon Jun 03, 2013 2:31 pm    Post subject: Reply with quote

Hi Thank you for the response. I recentrly rolled back to an old version, cause new one didn't work (still had intaller on my machine, uninstalled latest and re-intalled older version), but I still have config file that I created earlier (i don't see option to attach file in this forum):

System: Win 7 Prof 64Bit; SQL 2008R2 SSMS

File name: RedGate_SQLSourceControl_Engine_EngineOptions.xml
Folder: C:\Program Files (x86)\Red Gate\SQL Source Control 3

<?xml version="1.0" encoding="utf-8" standalone="yes"?>
<EngineOptions version="3" type="EngineOptions">
<IgnoreTfsPolicies>True</IgnoreTfsPolicies>
</EngineOptions>
Back to top
View user's profile Send private message
james.billings



Joined: 16 Jun 2010
Posts: 1112
Location: My desk.

PostPosted: Mon Jun 03, 2013 2:33 pm    Post subject: Reply with quote

Ah, the problem looks like you have created / edited the file in the wrong location. It isn't in Program Files, it's in your user profile (%localappdata%\Red Gate\SQL Source Control 3) - which would translate to "c:\users\<your username>\appdata\local\red gate\sql source control 3"
Back to top
View user's profile Send private message
eugef



Joined: 29 May 2013
Posts: 15

PostPosted: Mon Jun 03, 2013 3:04 pm    Post subject: Reply with quote

Oh, ok. thanks. I'll give it a try.

But still this is workaround, please, let me know when the real issue is resolved. Let me know if you need additional information for your investigation.
Back to top
View user's profile Send private message
james.billings



Joined: 16 Jun 2010
Posts: 1112
Location: My desk.

PostPosted: Mon Jun 03, 2013 3:08 pm    Post subject: Reply with quote

If you're able to just supply versions of SSMS, VS, TFS and the TFS Client DLL's on your machine, it may be of use in our investigation?
Back to top
View user's profile Send private message
eugef



Joined: 29 May 2013
Posts: 15

PostPosted: Mon Jun 03, 2013 3:26 pm    Post subject: Reply with quote

SSMS: 2008 R2 - 10.50.2500.0
VS: 2010 Ultimate - 10.402119.1 SP1Rel
TFS: 2010
Microsoft.TeamFoundation.VersionControl.Controls.dll - 10.0.40219.445

Let me know if you need additional information.
Back to top
View user's profile Send private message
james.billings



Joined: 16 Jun 2010
Posts: 1112
Location: My desk.

PostPosted: Mon Jun 03, 2013 3:27 pm    Post subject: Reply with quote

Thanks, I'll pass that on to the team
Back to top
View user's profile Send private message
mryhmln



Joined: 29 Aug 2011
Posts: 12

PostPosted: Wed Jun 12, 2013 3:57 pm    Post subject: I am getting the exact same issue with the newest version Reply with quote

VS 2010 Ultimate - 10.0.40219.1 SP1Rel
SSMS 2008 R2 10.50.1617.0
Don't know my version of TFS DLL.
Back to top
View user's profile Send private message
mryhmln



Joined: 29 Aug 2011
Posts: 12

PostPosted: Fri Jun 28, 2013 3:05 pm    Post subject: Any update on this issue? Reply with quote

We have a policy to require associating work items, but even when I attempt to associate a work item, I am getting a policy failure. I have to do an "ignorepolicies" and then go back and manually associate the changeset later. It is a hassle.
Back to top
View user's profile Send private message
james.billings



Joined: 16 Jun 2010
Posts: 1112
Location: My desk.

PostPosted: Fri Jun 28, 2013 3:17 pm    Post subject: Reply with quote

We're still investigating the full fix for this, but in the meantime you can disable policy checking completely to avoid having to add the comment. See here for details.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic All times are GMT + 1 Hour
Page 1 of 1

 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group